Volumio 3 Roon Bridge install failure

That’s what I thought you meant, but for me, even aplay -D volumio says no such device.

Sorry for sounding like I blamed your update for the Output Device list issue. My bad for not noticing the bug? in the first place.

I did update the plugin, but to be honest I don’t see any difference in functionality. Is there something I should look for?

No don’t stress, I’ll be in the same room as a Roon core and my raspberry pi in the next few days and I’ll sort it out. I saw a logic issue in the code that I thought was causing the justboom to be ignored for metadata, but I need to actually run it on my side to see what’s going on.

@birdietwin, just to confirm, after the update I pushed earlier, you haven’t noticed any change: Does that mean you’re still seeing metadata with your Schitt and the JustBoom, or has the metadata stopped working with the JustBoom?

In Roon I still show the Schiit Modi as the Audio device attached to the Justboom Digi for the Roon bridge.

In Volumio I see the snd_rpi_justboom_digi device listed with I2S on. The Modi only appears as a USB connected device with I2S off, except the snd_rpi_justboom_digi appears when I force the list to glitch.

Let me know if you need any more details.

Okay so you have your Schiit setup to go via USB when you want, and then through S/PDIF on the Justboom Digi when you want? You obviously just choose it in the Volumio Playback Options? With the code update I did, both ways still show metadata/album art/info?

Right. It is fixed. I had to change the way I looked for the device names that Roon sees.

@birdietwin just out of interest did you have to authorize my plugin as an extension in Roon? You shouldn’t need to (that was my intention), but all of a sudden mine wouldn’t work unless I did. Maybe Roon plugged the gap that I found?

I just refreshed the plugin with your update and can confirm that artwork now appears with I2S enabled and the S/PIF (snd_rpi_justboom_digi) selected. Perfect!.

I see a discovered Roon extension named “Dale Rider volroon - Roon Bridge on Volumio 0.1.1” but I did not need to approve it.

Thanks again for your work on this plugin. The quality of the audio through the Justboom Digi S/PDIF interface is superior to USB, especially on the Pi 3b+.

Let me know if I can be of further assistance to any future enhancements.

That’s great news. I hope you enjoy it!

I’m getting the install error on both of my x86 Volumio streamers.

Please try to install [PLUGIN] Volroon - Roon Bridge plugin with metadata and control

This plugin should be temporaly disabled until fixed.

Yes, I get the same error.

Could you please:

  1. Send the full log of the RoonBridge installing.
  2. Send your sources.list with cat /etc/apt/sources.list
  3. Mention your Volumio version

I’m a bit confused with what’s going on here. Are you seeing installation errors when trying to install Roon Bridge in the plugins store, the 2nd plugin on the page, or when trying to install my plugin, further down the page - Volroon? The error that’s being shown here probably still occurs with the original Roon Bridge plugin because it hasn’t been updated to change the http:// to https:// in its RoonBridge download path. Mine has had the change and does work for me, I just tried it again.

If it is my plugin - Volroon - that you’re experiencing problems with, please send logs as per @njiz post above.

I get the same error trying to install either plugin.

Downloading plugin at https://plugins.volumio.workers.dev/pluginsv2/download/volroon/1.0.4/volumio/buster/amd64
END DOWNLOAD: https://plugins.volumio.workers.dev/pluginsv2/download/volroon/1.0.4/volumio/buster/amd64
Creating install location
Unpacking plugin
Checking that the plugin is suitable for this version of Volumio The plugin can be used with this version of Volumio
Checking for duplicate plugin
Copying plugin to location
Installing necessary utilities
Installing volroon Dependencies
Downloading RoonBridge_linuxx64.tar.bz2 to /tmp/tmp.pJJlVokQCI/RoonBridge_linuxx64.tar.bz2
Unpacking RoonBridge_linuxx64.tar.bz2…
An error occured while decompressing RoonBridge_linuxx64.tar.bz2.
Exit Status: 2
Removing temp directory…
An error occurred while installing the plugin Error


Are you using Volumio 2 or Volumio 3?

Volumio 3

Hmmm. Same version I’m using. The only difference is I’m using RPi 4 and you are x64. I can’t replicate this problem at all on my side.

If you can SSH into your volumio instance and run some command line stuff? Please try first by typing: curl --version and let me know the version that shows up for you. Do the same with tar --version. Also send me the full install log by typing cat /tmp/installog. Following that, try to use curl to download the binary manually by typing this:

curl --write-out '%{http_code}' -sLfo "RoonBridge_linuxx64.tar.bz2" "https://download.roonlabs.net/bu

It should show “200” afterwards. If it does, try to extract it by typing tar xf RoonBridge_linuxx64.tar.bz2 and you should have a new folder wherever you started called RoonBridge. You can delete it by typing rm -rf ./RoonBridge

Letting me know at which point it fails will help to work this out.

I am not certain as I can also not replicate, but I think bzip2 has fallen outside of the apt package manager sources on x64, as exit error 2 means fatal error. You should indeed do what @charliesjcsays and/or try manually apt install bzip2

This is the version that shows.
curl 7.74.0 (x86_64-pc-linux-gnu) libcurl/7.74.0 OpenSSL/1.1.1n zlib/1.2.11 libidn2/2.0.5 libpsl/0.20.2 (+libidn2/2.0.5) libssh2/1.8.0 nghttp2/1.36.0 librtmp/2.3
Release-Date: 2020-12-09
Protocols: dict file ftp ftps gopher http https imap imaps ldap ldaps mqtt pop3 pop3s rtmp rtsp scp sftp smb smbs smtp smtps telnet tftp
Features: alt-svc AsynchDNS GSS-API HTTP2 HTTPS-proxy IDN IPv6 Kerberos Largefile libz NTLM NTLM_WB PSL SPNEGO SSL TLS-SRP UnixSockets

Tar version:
tar (GNU tar) 1.30
Copyright (C) 2017 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later https://gnu.org/licenses/gpl.html.
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.

Written by John Gilmore and Jay Fenlason.

Install Log:
Installing volroon Dependencies
Downloading RoonBridge_linuxx64.tar.bz2 to /tmp/tmp.DnkUzg55gU/RoonBridge_linuxx64.tar.bz2
Unpacking RoonBridge_linuxx64.tar.bz2…
An error occured while decompressing RoonBridge_linuxx64.tar.bz2.
Exit Status: 2
Removing temp directory…

When I entered curl --write-out ‘%{http_code}’ -sLfo “RoonBridge_linuxx64.tar.bz2” “https://download.roonlabs.net/bu
ilds/RoonBridge_linuxx64.tar.bz2” , it showed 000 (not 200)