Volumio 3 Buster Beta for X86

Would you please supply the information we are asking for when you submit a report?
I guess you have an Intel Atom with a realtek codec, but we need facts.

1 Like

Dear gkkpch,
sorry I am still a newbi with regards to Linux, logfile and output from “lspci” and “inxi -Fxxxz”. However, at least I am, so far, able to switch to /dev/, if needed :slight_smile: So, with some advice, I am surely able to help.
With regards to your question: The PC is a AZW Z83 II mini PC, with a Quad Core Atom x5-Z8350 with 2 MB Cache, 2 GB DDR3 RAM, 32GB eMMC System Disk, Intel HD Graphics 400, Realtek Gigabit LAN (RTL8168/8111G), Broadcom WiFi adapter (AP6255 + AP6212), BT 4.0 and a Realtek ALC5651 audio chip.
By the way, WiFi doesn’t work, but the LAN connection. Copying Volumio to the eMMC worked fine. With regards to the sound: the analog output works with Version 3.083 beta, it is called “headphone jack” .
With regards to sound I found this: “I tried several Linux distros, but all of them have trouble with sound. There is a driver for Linux Mint somewhere, but it only works for the headphone jack, so no sound via HDMI. Linux itself runs really fast and reliable on the device if you don’t need sound. I would recommend it if you want to use it as a server.”
Kind regards, Trollpferd

1 Like

We actually have some rules for joining the beta test program, see this post:wink:

However, the information you supplied will do for the moment, thank you for that.
We already knew that Intel Atom with the rt5640 codec (e.g. my HP Intel Atom test machine) has a serious issue since the latest audio changes, obviously your rt5651 has the same.
We don’t know yet what causes it, this may take a while to analyse, for a simple reason. x86 devices are not as “easy” as an RPi 4 for instance, which be only comes in one flavor. x86 devices come with thousands of different configurations.
None of the devs have a Z83II and the team cannot afford to go out and buy whatever test machine is needed.

We need time to find a way to organize this, meanwhile there is no way to support audio on some Intel Atom installations.
My only advice is to reinstall 3.077, which is the most stabile beta version we have for the Intel Atom platform.
I will let you know when there is progress.

Thank you for all your efforts! Great to know about the 3.077 as most stable Atom beta. Was wondering a bit why the later beta versions recently disappeared. Ich will of course observe the further development with this Realtek chip … :slight_smile: Alternatively, I also thought of using a DAC. Any experiences whether there is a DAC or USB soundcard that would work without specific drivers?
The WLAN issue is not really a topic for these devices as one could use LAN instead.
LG Trollpferd

System logs: http://logs.volumio.org/volumiobuster/TgZX0N0.html

I like to keep this thread about x86 beta testing only, just a short answer re. audio: all USB Class 2 DACs should work, they do not need a specific driver. In case you are looking for one with dsd direct capabilities, check this forum first, you can ask in the help section.

Regarding WLAN, does it not work at all or does it not show wireless networks? We really need a log.

OK, there is some AZW-specific firmware missing with WLAN, I can solve it, but not for 3.077

Sep 28 07:45:35 volumiopc kernel: brcmfmac mmc2:0001:1: Direct firmware load for brcm/brcmfmac43455-sdio.AZW-Z83 II.txt failed with error -2
Sep 28 07:45:35 volumiopc kernel: brcmfmac: brcmf_fw_alloc_request: using brcm/brcmfmac43455-sdio for chip BCM4345/6
Sep 28 07:45:35 volumiopc kernel: brcmfmac: brcmf_c_process_clm_blob: no clm_blob available (err=-2), device may have limited channels available
Sep 28 07:45:35 volumiopc kernel: brcmfmac: brcmf_c_preinit_dcmds: Firmware: BCM4345/6 wl0: Mar 1 2015 07:29:38 version 7.45.18 (r538002) FWID 01-6a2c8ad4

Thanks for your log, shows how important this is, also for others!

A big thanks on my side! With regards to the Z83-II mini pc: It is of equal difficulty to get the Windows drivers for this Broadcom WLAN module (and in general for the PC in total). The only chance is to get the original drivers is from someone who saved it from the original Windows installation on this PC. Generally one recommends to use one of these WLAN sticks that work without additional drivers. Z83-II mini pc (unlike its predecessor, Z83), btw, has an internal USB port that could be used. So the stick doesn’t even have to be visible :slight_smile: -). With regards to sound I am of course excited about any future progress with the Realtek ALC5651 audio chip. Generally it works, but as I have written, after a reboot, with 3.083 beta, I need to restart once before it works without stuttering/stopping (shut down via Volumio, start via the device knob). And, the current 3.101 beta only ends in distorted sound. KR/Trollpferd

it’s not the driver, it is only a piece of missing firmware.
I’ll add it to the next version.

:clap: :+1:

Another point with my Z83-II mini pc: I connected an USB stick at the internal USB drive of my unit and unplugged it afterwards (after “Save remove media”). However, the stick refuses to disappear in my library, see: http://logs.volumio.org/volumiobuster/kauapfC.html. Perhaps it is needed to update the library as well? KR, Trollpferd

3 posts were split to a new topic: Docker with Volumio 3.x

dear testers,
we had reports of a “boot error” after the OTA on machines used with legacy (syslinux) boot.
This problem has been located and fixed.
So, for all testers with those machines, please do a fresh flash, either with a version 3.101 or with one of the the upcoming version.

UEFI users are not affected by this bug.

You may be pleased to know, that I’ve just “alpha” tested an upcoming beta/rc1 and it seams the awfully screeching sound from the 3.101 has disappeared. Automatic switch between headphone and speakers also works again. But, this is with an rt5640 codec. You and I may have to work on getting it working on your rt5651 based Intel Atom soc, your help would be appreciated

3.112 works as intended for me. Thanks for Spotify connect. Have not checked multiroom (as this feature is not for me)


Calling for Intel Atom Baytrail/ Cherrytrail Users with rt5651 and es8316 codecs. I could use your help with improving onboard audio. Codec rt5640 already works, step to rt5651 should not be a big one. To avoid going offtopic in this thread, please send me an email at: ge.koerkamp (at) volumio.org


just had a look at version Volumiobuster-3.112-2021-10-08-x86_amd64.zip

Boot via USB Stick

There is no difference to version Volumiobuster-3.101-2021-09-08-x86_amd64.zip in my test results (see Volumio 3 Buster Beta for X86 - #253 by Robert.Hecht )

Here’s the log:

When playing hi res files via HDMI the first 5-10 seconds are broken. :x:
Not tested: multi room.

Plugin: Tested installation and function of “personal radio” - ok :white_check_mark:

KENKO Mini 150
Asrock J3455-ITX 4x 2,30GHz
CPU Intel Celeron/Pentium 4x 2,24GHz oder 4x 2,64GHz
4 GB 2x2GB DDR3-1333 SO-DIMM Kingston
SSD SATA3 1000GB Samsung 860 EVO
Intel HD Grafik

volumio@smx:~$ inxi -Fxxxz
System:    Host: smx Kernel: 5.10.70 x86_64 bits: 64 compiler: N/A Console: tty 0 dm: N/A
           Distro: Debian GNU/Linux 10 (buster)
Machine:   Type: Desktop Mobo: ASRock model: J3455-ITX serial: <filter> UEFI: American Megatrends v: P1.40
           date: 07/14/2017
CPU:       Topology: Quad Core model: Intel Celeron J3455 bits: 64 type: MCP arch: Goldmont rev: 9
           L2 cache: 1024 KiB
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 bogomips: 11980
           Speed: 2196 MHz min/max: 800/2300 MHz Core speeds (MHz): 1: 2211 2: 2196 3: 2219 4: 2197
Graphics:  Device-1: Intel vendor: ASRock driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:5a85
           Display: tty server: X.org 1.20.4 driver: modesetting unloaded: fbdev,vesa tty: 120x50
           Message: Unable to show advanced data. Required tool glxinfo missing.
Audio:     Device-1: Intel Atom/Celeron/Pentium Processor N4200/N3350/E3900 Series Audio Cluster vendor: ASRock
           driver: snd_hda_intel v: kernel bus ID: 00:0e.0 chip ID: 8086:5a98
           Sound Server: ALSA v: k5.10.70
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: ASRock driver: r8169 v: kernel
           port: e000 bus ID: 01:00.0 chip ID: 10ec:8168
           IF: eth0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:    Local Storage: total: 1.17 TiB used: 41.77 GiB (3.5%)
           ID-1: /dev/sda vendor: Samsung model: SSD 860 EVO 1TB size: 931.51 GiB speed: 6.0 Gb/s serial: <filter>
           rev: 1B6Q scheme: GPT
           ID-2: /dev/sdb type: USB vendor: SanDisk model: USB 3.2Gen1 size: 232.88 GiB serial: <filter> rev: 1.00
           scheme: MBR
           ID-3: /dev/sdc type: USB vendor: Intenso model: Rainbow Line size: 29.69 GiB serial: <filter> scheme: GPT
Partition: ID-1: / size: 25.35 GiB used: 38.7 MiB (0.1%) fs: overlay source: ERR-102
           ID-2: /boot size: 170.8 MiB used: 57.8 MiB (33.8%) fs: vfat dev: /dev/sdc1
Sensors:   Missing: Required tool sensors not installed. Check --recommends
Info:      Processes: 172 Uptime: 43m Memory: 3.70 GiB used: 634.2 MiB (16.7%) Init: systemd v: 241 runlevel: 5
           default: 2 Compilers: gcc: 8.3.0 alt: 8 Shell: bash v: 5.0.3 running in: tty 0 (SSH) inxi: 3.0.32

Cheers, Robert

Thanks for a straightforward review, other feedback has also been good so far. Log will be analysed

There is a new update out, this Release Candidate 1.

1 Like

We will start the next stage, volumio-3-rc1-open-beta-testing using a new, single thread for RPi, Tinkerboard and X86.
Therefore I’m closing this thread.

Note: There may still be x86-specific issues, like missing support for WiFi devices (onboard or dongles), onboard sound and DAC devices, disk devices etc.
Also, you could encounter boot issues or other problems of which you assume they are x86-related.

These issues are no longer considered beta-related and can occur in the future with new hardware or components.
Please post these in this help thread: x86-hardware-issues-wifi-dac-disks-etc