Volumio 3 Buster Beta for X86

please reread this important notice to all beta testers

To avoid further confusion, please unset Test mode if you have not done so already.
That way you will avoid stumbling over insufficiently tested or non-working alpha versions.
As @mervinio explained, sometimes you may specifically be asked by the developers to set Test mode and OTA to re-test a feature that you reported broken or not working correctly in a beta version.

Please hold on a little more, a new beta will arrive and be announced soon.

1 Like

Is alpha 3.102 only one (RP) plugin? It works btw. thanks for the continued effort.

Martin, it is better not to use 3.102 as this is an alpha and hardly tested.
My advice, unset Test mode and wait a few days until we announce a new beta.
Plugins are still very much WIP and not ready for field testing.

I know Ge. But I like living dangerously. (I have a stable beta on flash, should I need it) Thanks for all you do.

1 Like

There is a new beta version available, download it from this location:


1 Like


just tested: Volumiobuster-3.101-2021-09-08-x86_amd64.zip

After first boot:

  • the playback does work (tried webradio, TIDAL and local music lib). :white_check_mark:
  • index of local files (music library) scan or update does work. After plugging a USB device the scan starts automatically. :white_check_mark:
  • no startup sound at first boot :x:
  • WEB UI and local UI are working. :white_check_mark:

SPDIF ok, but there is a little cnack when switching manually from track to track :white_check_mark:
HDMI ok, but high resolution files sound broken over the first 5-10 seconds (MP3 96 kHz 32 bit, WAV 96 kHz 32 bit, WAV 192 kHz 32 bit, WAV 352.8 kHz 32 bit, DSD 2.82 MHz 1 bit, DSD 5.64 MHz 1 bit, DSD 11.28 MHz 1 bit, flac 96 kHz 24 bit, ) :x:
analogue out ok (SPDIF stays “on”) :white_check_mark:
Testfiles ok, various formats and resolutions mp3(44.1, 48kHz @ 16bit 24bit), flac(44.1, 48, 96, 192kHz @ 16bit 24bit), wav(44.1, 48, 96, 192, 352.8kHz @ 32bit), DSD (2.82, 5.64MHz @ 1bit)
Webradio ok :white_check_mark:
myVolumio ok :white_check_mark:
TIDAL ok :white_check_mark:
Qobuz not tested
music lib index ok (artists, albums, tracks, playtime) :white_check_mark:
ssh / logs ok :white_check_mark:
samba ok :white_check_mark:
plugins nok - not yet available for x86/amd64, WIP, known issue
local UI ok :white_check_mark:
WEB UI ok :white_check_mark:
USB automount ok :white_check_mark:
LAN ok :white_check_mark:
WLAN not tested
Network Drives not tested
update not tested
startup sound ok (not at first boot)
alarm not tested
aleep not tested

volumio@smx:~$ inxi -Fxxxz
System: Host: smx Kernel: 5.10.60 x86_64 bits: 64 compiler: N/A Console: tty 0 dm: N/A Distro: Debian GNU/Linux 10 (buster)
Machine: Type: Desktop Mobo: ASRock model: J3455-ITX serial: UEFI: American Megatrends v: P1.40 date: 07/14/2017
CPU: Topology: Quad Core model: Intel Celeron J3455 bits: 64 type: MCP arch: Goldmont rev: 9 L2 cache: 1024 KiB
flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 bogomips: 11980
Speed: 2196 MHz min/max: 800/2300 MHz Core speeds (MHz): 1: 2194 2: 2236 3: 2196 4: 2243
Graphics: Device-1: Intel vendor: ASRock driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:5a85
Display: tty server: X.org 1.20.4 driver: modesetting unloaded: fbdev,vesa tty: 198x50
Message: Unable to show advanced data. Required tool glxinfo missing.
Audio: Device-1: Intel Atom/Celeron/Pentium Processor N4200/N3350/E3900 Series Audio Cluster vendor: ASRock
driver: snd_hda_intel v: kernel bus ID: 00:0e.0 chip ID: 8086:5a98
Sound Server: ALSA v: k5.10.60
Network: Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: ASRock driver: r8169 v: kernel port: e000
bus ID: 01:00.0 chip ID: 10ec:8168
IF: eth0 state: up speed: 1000 Mbps duplex: full mac:
Drives: Local Storage: total: 1018.48 GiB used: 4.93 GiB (0.5%)
ID-1: /dev/sda vendor: Samsung model: SSD 860 EVO 1TB size: 931.51 GiB speed: 6.0 Gb/s serial: rev: 1B6Q
scheme: GPT
ID-2: /dev/sdb type: USB vendor: Intenso model: Rainbow Line size: 29.69 GiB serial: scheme: GPT
ID-3: /dev/sdc type: USB vendor: SanDisk model: Ultra Fit size: 57.28 GiB serial: rev: 1.00 scheme: GPT
Partition: ID-1: / size: 25.35 GiB used: 80.1 MiB (0.3%) fs: overlay source: ERR-102
ID-2: /boot size: 170.8 MiB used: 57.8 MiB (33.8%) fs: vfat dev: /dev/sdb1
Sensors: Missing: Required tool sensors not installed. Check --recommends
Info: Processes: 173 Uptime: 26m Memory: 3.70 GiB used: 637.5 MiB (16.8%) Init: systemd v: 241 runlevel: 5 default: 2
Compilers: gcc: 8.3.0 alt: 8 Shell: bash v: 5.0.3 running in: tty 0 (SSH) inxi: 3.0.32


Works great so far!

Dear all,
I am very happy to contribute to this forum :slight_smile: After using Volumio for quite a few years I moved from a Raspberry Pi II to the PC platform. Reason is speed an more reliability (no more disappearing USB drives, faster responding GUI). I am currently using a AZW Z83 II. Brand names were Beelink, Bqeel, Cover Factory, Kodlix, MFY, Tictid and so on. They do all have an Atom Z8350 processor inside and look pretty much the same. Currently, these units are available for 50 to 70 €. When switching to Volumio on PC, it seems, I was lucky enough, to start with the “right” version: Version 3.083 beta works, even though there are some limitations: only analogue output, SD card reader not working, and, most important, each and every time, after a first boot, the unit needs a re-boot (by powering down from within Volumio, and pressing the on/off switch of the unit. If not, sound output stops after some seconds). As I tried to get rid of these limitations i also tried other versions, but with no luck: With version 2.909 no audio device was available , 4K screen wasn’t in native resolution, screen output with errors, USB stick not recognized etc.
Now I tried the newest beta, Volumiobuster-3.101-2021-09-08-x86_amd64.zip: This results in a totally disorted sound, also stoping after one or two seconds. Meaning: not usable. So, something must have been lost on the way from Version 3.083 to Version 3.101.
Having written this, I am happy to contribute whatever you might need to overcome this
Kind regards, Trollpferd

Would you please supply the information we are asking for when you submit a report?
I guess you have an Intel Atom with a realtek codec, but we need facts.

1 Like

Dear gkkpch,
sorry I am still a newbi with regards to Linux, logfile and output from “lspci” and “inxi -Fxxxz”. However, at least I am, so far, able to switch to /dev/, if needed :slight_smile: So, with some advice, I am surely able to help.
With regards to your question: The PC is a AZW Z83 II mini PC, with a Quad Core Atom x5-Z8350 with 2 MB Cache, 2 GB DDR3 RAM, 32GB eMMC System Disk, Intel HD Graphics 400, Realtek Gigabit LAN (RTL8168/8111G), Broadcom WiFi adapter (AP6255 + AP6212), BT 4.0 and a Realtek ALC5651 audio chip.
By the way, WiFi doesn’t work, but the LAN connection. Copying Volumio to the eMMC worked fine. With regards to the sound: the analog output works with Version 3.083 beta, it is called “headphone jack” .
With regards to sound I found this: “I tried several Linux distros, but all of them have trouble with sound. There is a driver for Linux Mint somewhere, but it only works for the headphone jack, so no sound via HDMI. Linux itself runs really fast and reliable on the device if you don’t need sound. I would recommend it if you want to use it as a server.”
Kind regards, Trollpferd

1 Like

We actually have some rules for joining the beta test program, see this post:wink:

However, the information you supplied will do for the moment, thank you for that.
We already knew that Intel Atom with the rt5640 codec (e.g. my HP Intel Atom test machine) has a serious issue since the latest audio changes, obviously your rt5651 has the same.
We don’t know yet what causes it, this may take a while to analyse, for a simple reason. x86 devices are not as “easy” as an RPi 4 for instance, which be only comes in one flavor. x86 devices come with thousands of different configurations.
None of the devs have a Z83II and the team cannot afford to go out and buy whatever test machine is needed.

We need time to find a way to organize this, meanwhile there is no way to support audio on some Intel Atom installations.
My only advice is to reinstall 3.077, which is the most stabile beta version we have for the Intel Atom platform.
I will let you know when there is progress.

Thank you for all your efforts! Great to know about the 3.077 as most stable Atom beta. Was wondering a bit why the later beta versions recently disappeared. Ich will of course observe the further development with this Realtek chip … :slight_smile: Alternatively, I also thought of using a DAC. Any experiences whether there is a DAC or USB soundcard that would work without specific drivers?
The WLAN issue is not really a topic for these devices as one could use LAN instead.
LG Trollpferd

System logs: http://logs.volumio.org/volumiobuster/TgZX0N0.html

I like to keep this thread about x86 beta testing only, just a short answer re. audio: all USB Class 2 DACs should work, they do not need a specific driver. In case you are looking for one with dsd direct capabilities, check this forum first, you can ask in the help section.

Regarding WLAN, does it not work at all or does it not show wireless networks? We really need a log.

OK, there is some AZW-specific firmware missing with WLAN, I can solve it, but not for 3.077

Sep 28 07:45:35 volumiopc kernel: brcmfmac mmc2:0001:1: Direct firmware load for brcm/brcmfmac43455-sdio.AZW-Z83 II.txt failed with error -2
Sep 28 07:45:35 volumiopc kernel: brcmfmac: brcmf_fw_alloc_request: using brcm/brcmfmac43455-sdio for chip BCM4345/6
Sep 28 07:45:35 volumiopc kernel: brcmfmac: brcmf_c_process_clm_blob: no clm_blob available (err=-2), device may have limited channels available
Sep 28 07:45:35 volumiopc kernel: brcmfmac: brcmf_c_preinit_dcmds: Firmware: BCM4345/6 wl0: Mar 1 2015 07:29:38 version 7.45.18 (r538002) FWID 01-6a2c8ad4

Thanks for your log, shows how important this is, also for others!

A big thanks on my side! With regards to the Z83-II mini pc: It is of equal difficulty to get the Windows drivers for this Broadcom WLAN module (and in general for the PC in total). The only chance is to get the original drivers is from someone who saved it from the original Windows installation on this PC. Generally one recommends to use one of these WLAN sticks that work without additional drivers. Z83-II mini pc (unlike its predecessor, Z83), btw, has an internal USB port that could be used. So the stick doesn’t even have to be visible :slight_smile: -). With regards to sound I am of course excited about any future progress with the Realtek ALC5651 audio chip. Generally it works, but as I have written, after a reboot, with 3.083 beta, I need to restart once before it works without stuttering/stopping (shut down via Volumio, start via the device knob). And, the current 3.101 beta only ends in distorted sound. KR/Trollpferd

it’s not the driver, it is only a piece of missing firmware.
I’ll add it to the next version.

:clap: :+1:

Another point with my Z83-II mini pc: I connected an USB stick at the internal USB drive of my unit and unplugged it afterwards (after “Save remove media”). However, the stick refuses to disappear in my library, see: http://logs.volumio.org/volumiobuster/kauapfC.html. Perhaps it is needed to update the library as well? KR, Trollpferd

3 posts were split to a new topic: Docker with Volumio 3.x

dear testers,
we had reports of a “boot error” after the OTA on machines used with legacy (syslinux) boot.
This problem has been located and fixed.
So, for all testers with those machines, please do a fresh flash, either with a version 3.101 or with one of the the upcoming version.

UEFI users are not affected by this bug.