Volumio 3 Buster Beta for RPi

al those things are still for the 2.xx version not all will work on 3.0.51

Strangely the error message says: “Failed to open ALSO devidce Volumio”, whereas this should be a HW identifier.

Just to confirm that the ALSA device should be volumio whatever your audio hardware device is. This is part of the update to Volumio 3.x, where the ALSA pipeline has more of a role for plugins and audio routing.

4 posts were split to a new topic: Timezone Setting & Daylight Saving Time

Not specific to Buster beta thread

Installed Volumiobuster-3.051-2021-03-06-pi.img on
RPi 3 with BassFly uHat. Seems all to work till now, will play with it
and give feedback as and when required.


1 Like


Earlier I reported problems with playing some albums from Artist menu (1 Mar)

The problems I found are under Artists some albums do not play when clicking the Play button and nor from the three dot menu. But tracks from the Album shows below and works from ther. When clicking the album name it says “No item”
Etc. Etc.

That problem occurred when the meta tag Albumartist was missing (and there is A LOT of missing tags in my library :slight_smile: )
My solution was to change the Music Library Setting - Sort Artists by to Artist

Note: The problem is not in Volumio 2 versions


I have a Raspberry Pi 4 and Volumio 3.0.51
A Dac Amp Suptronics X450

Actually i manage to get it working listening internet radio, it works with Generic_i2s_dac and hifiberry_dac

I have this error in dmesg:
snd-rpi-simple soc:sound: ASoC: failed to init link HifiBerry DAC: -517
[ 15.671780] snd-rpi-simple soc:sound: ASoC: failed to init link HifiBerry DAC: -517
[ 15.703929] snd-rpi-simple soc:sound: pcm5102a-hifi <-> fe203000.i2s mapping ok
[ 15.824878] cfg80211: Loaded X.509 cert ‘sforshee: 00b28ddf47aef9cea7’
[ 16.005820] brcmfmac: F1 signature read @0x18000000=0x15264345
[ 16.014814] brcmfmac: brcmf_fw_alloc_request: using brcm/brcmfmac43455-sdio for chip BCM4345/6
[ 16.018373] usbcore: registered new interface driver brcmfmac
[ 16.131907] brcmfmac mmc1:0001:1: Direct firmware load for brcm/brcmfmac43455-sdio.raspberrypi,4-model-b.txt failed with error -2
[ 16.444869] brcmfmac: brcmf_fw_alloc_request: using brcm/brcmfmac43455-sdio for chip BCM4345/6
[ 16.482561] brcmfmac: brcmf_c_preinit_dcmds: Firmware: BCM4345/6 wl0: Jan 4 2021 19:56:29 version 7.45.229 (617f1f5 CY) FWID 01-2dbd9d2e
[ 17.581496] 8021q: 802.1Q VLAN Support v1.8
[ 17.676455] brcmfmac: brcmf_cfg80211_set_power_mgmt: power save disabled

It seems that the second error is relative to wifi firmware, and i don’t understand the first error relative to sound
Should i have to test with different settins in i2S dac

The mixer is software
and the volume is apparently lower with hifiberry_ dac than with generic_i2s_dac

Is there a person who can comment or have a hint concerning suptronics x450 ?

Thanks in advance for any input or question

No, but you could help by submitting a full log and not just an extract.
There will be more info in there.
e.g. error -517 is not necessarily wrong, it depends on when it happens and what else during boot.

Howto: Send a log

The firmware “issue” is referring to the RPi4 wifi. Does wifi work? (As gkkpch says, messages in dmesg can simply be ‘informative’ rather than crucial).

1 Like

Just found a little bug with OTA updates, the file /boot/userconfig.txt is overwritten with the default one (it should not be the case, the content of this file should be maintained upon updates)

So far pretty content with version Volumiobuster-3.061 on the rPI-4-8GB.
The pro-ject pre box S2 digital is working and sounds perfect.
There is a big improvement on the stability of the Tidal and Qobuz integration.
With version2 it lagged, crashed and had a mind of it’s own. The only way to mess them up in V3 is rapidly skipping back or forward. Then it looses count and Volumio does whatever it desires. :flushed:

Not sure what the loopback thingy is doing in the left menu?

Some suggestions:

  • Make timezone and localization setting part of the setup.
  • During the library scan (50000 tracks), the spinning wheel is not persistence. So it seems done, but then only 10% has been scanned, while it is still scanning.

Found one issue with Qobuz on the iPhone, when using airplay to volumio, volumio drops the connection. After turning shairport off/on in volumio i can reconnect. But nothing is being played.

Now the being pigheaded part (No need to offer solutions as it is not part of Beta testing):

  • Spotify plugin (Team volumio) installed, showing track info, but no audio yet.
  • MPD Oled plugin is working, including CAVA for Tidal, Qobuz and Music library.
  • GPIO plugins complains on kew. So did the Spotify plugin. But that solution didn’t work for GPIO

Conclusion, I’ll stick with V3 as the beta seems more promising/stable than V2, which caused me almost to move back to JRiver.


@gkkpch could you please kindly post the v 3.068 for the rpi buster beta.
@2acd needed for a fresh install
Many thanks.

just set test mode and do an OTA.
3.061 is the latest.


[Volumio 3.061 & Realtek 8192EU] Confirmation works after driver download and install


Tried the 3.061 image with Raspberry Pi 3, Suptronics X5000 DAC & Amp, USB Wifi dongle from TP-Link using Realtek 8192EU.
A. Doesn’t work out of the box
B. Work after performing the recommended action

sudo wget http://downloads.fars-robotics.net/wifi-drivers/install-wifi -O /usr/bin/install-wifi
sudo chmod +x /usr/bin/install-wifi
sudo install-wifi

and restarting.
C. Just one question = would the driver be integrated in the future ? if not, would the same process (driver install) need to be done after each update?

Have a nice day.

1 Like

Support for RTL8192EU is already present as far as I know (at least I remember using it years ago, and it’s in the compatibility list). Strange, have you tried the dongle with Volumio 2 by any chance?

There are a number of wifi drivers missing in Volumio 3.0 for PI, see earlier posts and the corresponding reply from @ashthespy

any plans to add PIP3 so people who use hifiberry’s DSP can run “Dsptoolkit” , currently as soon as I install PIP3 the system gets unstable , 50% of the time it is not able to show system settings etc.
After I installed dsptoolkit the complete system just slows down where music is having 1sec+ jitter.
Only test I have not done is just opening SPI and see the result

Please post feature requests in the appropriate places.
There is no room for adding new features during the Volumio 3 beta testing. Our goal is to get this version as stable as possible with
the functionality that was planned for it.

V 3.063 rpi
Same issue present :
Userconfig.txt is not preserved. Is overwritten with default values during update process.


Partly replied by gkkpch already, as of today
a. no issue with Volumio 2, RTL8192EU based wifi dongles work out of the box.
b. it is not the case with the current beta of Volumio 3 (at least 051 and 061), the specific drivers have not been included (yet?)
yet, after sshing into the Volumio3, giving the command above & rebooting, it works.

Have a nice day

4 posts were merged into an existing topic: [NOT RECOMENDED!] Plugin adventures on Buster betas