Volumio 2 on Odroid Boards

Found another way to work around the build problem.

When creating your mount points in the *image.sh file. Create a second rootfs directory and mount bind it to the rootfs directory.

mkdir /mnt/volumio/rootfs-bind
mkdir /mnt/volumio/rootfs
mount /mnt/volumio/rootfs-bind /mnt/volumio/rootfs -o bind

As far as removing the hook funtions goes it’s looking good so far. Have been commenting them out and so far nothing has ended up broken.

New version of Odroid C2 has been built, OP has been updated

The previous Odroid releases obviously had an issue with unloading the aml_i2c module after no HiFi Shield 2 was found.
For a normal user, this has no consequences, that is why it was discovered so late.
But for people handling additional I2C devices (e.g. for DIY projects), this is a real issue.

It will be fixed in the next release, meanwhile a temporary fix is available (removing the offending line from /opt/odroiddac.sh)

1 Like

New version v2.395 for Odroid C1/C2 has been built, OP has been updated

Dear gkkpch, dear community,

Downloaded image file ( build on 20.04.2018), written to EMMC, is working well out of the box, as a basic configuration.
Nice work. Thank You a lot.

  • HIFI Shield+ detected, working.
  • USB DAC Topping D30 detected, working, volume controll OK.

But I have trouble with installation of plugins available via user interface. Installation of plugins end with message “Plugin successfully installed”, usually without “close” button.
After system restart the newly installed plugin appear in “installed plugin” window. Switching them “ON”, the user interface restarts, and nothing happen. They are still in “OFF” state. And does not appear in “browse” window ( spotify, youtube), only Touch Screen start to work, so I can run on C2 volumio user interface.

Currently i have tried with next plugins :

  • Touch Display
  • Spotify
  • Tunein Radio
  • Spotify Connect 2
  • Youtube

Have You any idea how to make “ON” ( active) plugins ?

Best regards,

Here is the message from system journal :

Apr 21 11:43:14 volumio volumio[27410]: |||||||||||||||||||||||| WARNING: FATAL ERROR |||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||
Apr 21 11:43:14 volumio volumio[27410]: TypeError: Cannot read property ‘bind’ of undefined
Apr 21 11:43:14 volumio volumio[27410]: at PluginManager.enableAndStartPlugin (/volumio/app/pluginmanager.js:1830:25)
Apr 21 11:43:14 volumio volumio[27410]: at CoreCommandRouter.enableAndStartPlugin (/volumio/app/index.js:1414:28)
Apr 21 11:43:14 volumio volumio[27410]: at Socket. (/volumio/app/plugins/user_interface/websocket/index.js:1220:44)
Apr 21 11:43:14 volumio volumio[27410]: at emitTwo (events.js:106:13)
Apr 21 11:43:14 volumio volumio[27410]: at Socket.emit (events.js:191:7)
Apr 21 11:43:14 volumio volumio[27410]: at /volumio/node_modules/socket.io/lib/socket.js:503:12
Apr 21 11:43:14 volumio volumio[27410]: at _combinedTickCallback (internal/process/next_tick.js:73:7)
Apr 21 11:43:14 volumio volumio[27410]: at process._tickCallback (internal/process/next_tick.js:104:9)
Apr 21 11:43:14 volumio volumio[27410]: |||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||

It is not a typical odroid issue as it occurs in the volumio part, not the OS.
Unless there was something wrong with volumio at the time of building, therefore I need to verify this.
I might need the log from your installation process, because the issue probably starts there.


i hope I can find required logs, if You help me where can I locate them, ( and how) …
But if You like I can reinstall volumio from Your ZIP … I have whole night for this :slight_smile:

A fresh install would be good, then install the plugins and immediately afterwards send a log from the local.volumio/ dev page.
I need the url that is returned to you after sending.

ok, fresh install is on the way …

fresh install -> finishing install wizzard -> media library scan in progress.
The log file is here : logs.volumio.org/volumio/abgRNp3.html

Installig Soptify plugin for Volumio2 -> Plugin installed successfully -> CLOSE, then log file generation. The log : logs.volumio.org/volumio/BwENvk2.html

activate spotify plugin -> volumio restarts -> log file : logs.volumio.org/volumio/4MeqO1a.html

The image has been rebuilt, ready to test. You ought to download it once more (today’s version).
I was not able to test Spotify as I canceled my account, but the touch screen plugin installs and activates fine.
Could you try once more, if it still doesn’t work, we need to look at your installation in more detail.


2018-04-22 version installed to SD ( not to EMMC, because I revert my EMMC to previous 2.344 2017-12–16, but multiboot version, works perfectly).

  • Basic Install OK.
  • Touch Dispaly, Spotify, LastFM, Spotify Connect2, IR Remote, installed OK ( some of them had no close button), but setting them to “ON” ( active) hangs up and restart volumio.
  • Youtube, Simple EQ, GPIO install ended with : “The following error occurred when installing the plugin: TypeError: Cannot read property ‘name’ of undefined”
  • TuneIn install ended with : “The following error occurred when installing the plugin: Error”

Here is the log : logs.volumio.org/volumio/Lrb7czv.html

The board is ODROID C2 - REV 0.2 - 20160226, network is connected via cable, no wifi dongle, no any usb devices, only HiFi Shield+, and HDMI. Power adaptor is tandard odroids 2.5 A.

How can I help You ?

After restart, installed plugins disappeared from “installed plugins list”…

I can confirm we have issues with plugins, just tried to activate the Spotify plugin and this seems to restart volumio and results in still being inactive.
Unclear why this could be C2-specific, perhaps some regression further down the Volumio line.

Hi Gkkpch

One request, is it possible to get a armbian 4.17 kernel based Volumio build for odorid c2?

Trying to do it myself but my Linux skill is not up to the task…

Really appreciate the help.


though the 4.17 kernel works very well with the C2, I have no intention to make it available until Baylibre adds the i2s drivers we so desperately need to run the HiFi shield.
I’m on the mailing list for Amlogic progress, but nothing has popped up yet in that direction.
They are already working on 4.18, so I guess we won’t get anything before 4.19 (or even later).

My experience with a C2 has been lovely, but at the end of the day we are reliant on upstream updates for kernel and device support. It’s the one thing that keeps driving me back to RPis for their support.