Volumio 2 on Odroid Boards

Thank you. Would it be possible to get customised version for Odroid? I’m thinking of starting to make streamers commercially.

possibly, there is a form for it, see the contact link at the bottom of the volumio.org home page. Fill in your email and the message. They may also suggest alternatives as these boards are old and Hardkernel already announced EOL for C2. I believe C1 may follow soon.

Thank you! C1+ will be discontinued too, but the C4 will continue. I have a small stock of C1+. Odroid sounds better then other boards.

thanks for the update … I will try the latest version soon … I fell back on your latest c1+ version using the hifishield 2 and that is working VERY well. crisp sound, well defined sound and no noise (I do use an ultra linear powersupply (5V - 25W) and for the amplifier I am using a 3KW power shaper (as where I live in Thailand there is a LOT of noise and SPIKES on the 220v (it changes between 244 and 218 V on a regular base (like every 5 min))
Many thanks for the great effort you are putting into this project …,.

one question : MOODE is getting some attention but it is only available for the RPI … it seems to have less problems on start up and the audio reviews are pretty good . Would it be possible to port MoOde to the hardkernel family?


Why would anyone want to change from Volumio to Moode :see_no_evil:
On a serious note, don’t ask Volumio devs, ask the founder whether you can do this. The fact that after all the years it still only runs on PI probably says enough.

Anyway, consider switching to a C4 if you like Hardkernel’s work.
C2 is EOL (production stopped) and C1+ won’t be long either.
But, as long as they function…

Note: Odroid Volumio 3 Beta kickoff

Version 2.877 is out, see OP

I’m trying to get the I2S pins to work by changing the settings in the user.boot.ini file.

Your instructions state to uncomment these setting:


The new user.boot.ini file in version 2.877 only has:


Not sure changes need to happen to the file?

oops, need to check the C4.
Likely our Volumio 3 beta has something to do with it, perhaps I overlooked something.
I will disable downloads for the time being and investigate.
Thanks for reporting!

Confirmed, a fix for the beta causes regression with volumio 2 shield users, missed that.
My plan is to fix this the next day or so.

This has now been fixed, see the Opening Post.
You can use the downloaded 2.877 version following the modified Note on DAC usage
Sorry for the confusion.

ok thanks

So would I modify it like this?


yes, then reboot

I tried typing both of ways below and neither worked. Let me know what I’m doing wrong.

Screenshot from 2021-04-20 16-24-57

Screenshot from 2021-04-20 16-25-14

nevermind I figured it out.

I used Odroid-HIfi vs Hifi2 and it worked.

glad you found a way to get it to work.
Which DAC are you connecting?

Audio GD NFB-27h ºÍ§Ó­µ响

I connect directly to the 7 pin connector to get I2S to my DAC

ok, thanks!

Can we get a new released build for C2 with the new feature of Tidal Connect please?
Many thanks in advance! :+1:

Tested, but appears not be working working at all with either C1 and C2, the endpoints are visible in Tidal, but there is no sound. I really hope it is not due to the old kernel.
There is a new TC integration coming in a few days with a number of fixes, perhaps we’re lucky.

1 Like