Volumio 2.031 Multiroom switching via Webinterface

Hi all, after updating to Volumio 2.031 switching between rooms with browser doesn’t work anymore…
Devices are shown (without cover-art), but selecting a device will only display the circling dots…
selecting the devices via ip works in browser as before…

i guess i will downgrade it back to ver 2.001

kindest Count

same problem for me…

funny detail…switiching from Volumio device with 2.001 to device with 2.031 works…but cannot go back

Thanks for reporting, I located the issue and will be fixed this week. Could you please open a bug report on github?

Hi Michelangelo,

First of all, VOLUMIO IS GREAT. THX!!!
I use 3 Raspi and I am missing the Multiroom switching option since the update…
When do you think you have some time to fix this bug?
This would be really nice :smiley:

I have no idea how to post a bug on github. Sorry


Fixed yesterday evening, update available :wink:

Update done, works again :smiley: :smiley:

Thank you


I am completely missing that overlay since the last update… Do I have to activate it somewhere? updatet from 31 to 41

any ideas to that?

It appears automagically when there is more than one device on a network, in my case.

not working for me and my 3x2.041 pies (2xpi0, 1xpi3)

Hi, i have the same Problem 1xPI2 1xPI3 bot volumio with 2.041
are there any fixes possible?

I also have issues with switching between the multiroom instances from the Volumio WebUI.

2 RPi’s both on WiFi running Volumio 2.041, one is named ‘Zolder’ (dutch for Attic) and one is named Woonkamer (Living).

I can access both individually through the URLs ‘zolder.local’ and through ‘woonkamer.local’. The UI of both instances show the two Volumio instances in the Multiroom section, including the last track name. However, when I then attempt to access the other instance by clicking it, I briefly see the UI changing but then the UI reloads the original UI. So switching is impossible.

I tried several different platforms (PC running Chrome, IPhone, IPad). To me this seems a UI issue.
I get the same behavior when opening the UI through the URL ‘volumio.local’.

Anyone having a solution for this?

For me this issue is now solved. In my case it was caused by the Pi’s poor WiFi connection, which made them jump between two access points, or by re-establishing a new connection regularly. As a result they received a different IP address, which I guess caused the issue.

In my router config, I’ve now setup reserved IP addresses for the Pi’s, so when they reconnect, they will be given the same IP address. Since I’ve changed this config, the multiroom automagically works :sunglasses:


maybe i have the same problem using 2.041

I have a Raspi 3 with a 5" Touchscreen Display as the main audio device and a Raspi 2 client.

I can start music on the client using the main device. But if i switch back on the main device to the main device (using touchscreen) the update circle never stops.

It also happens if i switch to client and back to main Volumio.

But i can still mange both devices usint the website from a third PC.

2017-02-12T17:08:46.312Z - info: [1486919326311] parsing response...
2017-02-12T17:08:46.313Z - info: [1486919326312] ControllerMpd::parseTrackInfo
2017-02-12T17:08:46.314Z - info: [1486919326314] ControllerMpd::pushState
2017-02-12T17:08:46.315Z - info: CoreCommandRouter::servicePushState
2017-02-12T17:08:46.316Z - info: [1486919326316] CoreStateMachine::syncState
2017-02-12T17:08:46.317Z - info: [1486919326317] CorePlayQueue::getTrack 2
2017-02-12T17:08:46.318Z - info: [1486919326317] Received update from a service different from the one supposed to be playing music. Skipping notification.Current webradio R$
2017-02-12T17:08:46.320Z - info: [1486919326319] ------------------------------ 91ms

In this case i started a webradio stream.

I changed hostname and samba name on both devices.

Any ideas?