USB Waveio (xmos) clicks odroid C2

Ok, thank you. Do you mean try those variations in nrpacks With the affinity fix too or without the affinity fix?

Incidentally theres a problem with the restart/reboot command, booth in WebUI and in ssh. They won’t work properly. Every time I make a change y must disconnect and reconnect the power supply cable. Do you know if this a know problem on Odroid C2-Volumio?

I’ve just change the sd card. Reboot is working normally again!

OK, then please remove index=1 from the line and try again.
Then if it works you might have to experiment a bit with nrpacks=x where x lower than 8 or try with a few values higher than 8 (10,12,20)
Hi, I’ve change the nrpacks value with no success. I’ve tried with 1-8, 10, 12, 20. As I’ve said, the affinity fix works only for 44.1/16, frequencies and bith depth over that give a lot of clicks and pops on playback. :frowning:

That leaves me without any ideas at the moment. With some devices the cpu affinity change works, sometimes changing the amount of audio being sent in each burst to the usb interface helps. In your case, none of it seems to work…


I have the same issue, using stello u3 usb to spdif converter based on xmos chipset with odroid c2. Random clics and pops, but ir i do factory reset, odroid c2 reboots and sound is clean:) sometimes on first boot no pops and clics, very strange. So my factory reset is temporary fix:)

I had the same problems with my USB-XMOS-DAC - many clicks and pops. A factory reset solved my problem.
I’m playing music on my Odroid C2 for about 2 days continuously now without problems.
To prove my solution, could anyone with the same problem do a short test:
When there are clicks during playback of music do:

  • Stop playing
  • Login via a remote session and do:
  • sudo service mpd stop
  • Wait a few seconds and then
  • sudo service mpd start
  • Are there any error messages when restarting mpd?
  • If so, could you please post your mpd.conf and the error messages ?

forget my last post. After changing some volume settings and doing a reboot the clicks and pops where back again. I tried soft- and hard reboot but with no success. Then I decided to play some mp3 files. They all played without pops and clicks - strange. But what drives me crazy - the hires files (FLAC) that I played after the mp3 files also had no pops and clicks. After getting such strange results, I’m convinced, this is not a kernel problem, this is a problem with the audio player software.

Strange, for me the same, touched volume control and clicks returned:(((( no help from factory reset…

Hi, the same issue for me, tryed change affinity to cpu#3 clicks are gone , nice:) works only to normal usb ports on odroid c2. Oth port still with click and pops. Please in next revisiod add this command to startup, thanks:)

This was done 3 weeks ago, but we have not released a new version of the image yet. There a a few more usb audio reports that need to be looked into first.

just for information, I spent one day to setup an audioplayer on Odroid C2 based on Armbian 5.20 server (same kernel as volumio 2.030).
I used mplayer as backend and openhome mediaplayer as frontend. Had no pops or clicks with this configuration, but one bug in openhome mediaplayer. Each new song started with max. volume for the first few milliseconds. That is really very annoying too.

Ok, are you ready/ willing to test a new dev image? Two others have tested with other non-working usb audio devices and feedback has been excellent.

BTW. if others reading this, having problems with their usb dac and willing to test, send me PM.


@xuser and @lowrideris: you have a PM


please do not add to this thread any further, HK confirmed having issues with the amlogic usb driver, which are now being followed up.
You could help by answering my question on and add any additional information/ questions there.

I will try to get an official C2 image published with a preliminary usb fix soon.