UPnP / DLNA Renderer

do I have to enable the UPnP/DLNA renderer somehow? I installed volumio on my raspberry pi 3 and I can connect and play via the webUI but I don’t see a it as a renderer in my UPnP app (bubbleupnp on an android phone).
I googled but couldn’t find any information in the forum or the documentation.


yes, documentation will get better
and here is the link that should answer your question, normally
to find other links, try “minidlna” when searching the forum

Hi thanks for your answer but I was asking about the rendering point (aka player) not the library server. I have a minimserver on my NAS that manages my library. However I switched out my power/AC adapter and now it seems to work, yay. very interesting, I would have thought that the whole system would crash if there was insufficient power and not only some services not starting.

edit: nay, it wasn’t the AC apparently. Just when I started up my pi today the renderer was gone and I even had to use the IP to access the webUI. I now tried to follow andrea.iob s advice [1] and added

# UPnP network interface upnpiface = wlan0
to /etc/upmpdcli.conf
after a reboot the renderer now shows up again but I am not too sure it that isn’t just a coincidence.
I will post a follow up here if it works now consistently.

edit2: it was indeed a coincidence
[spoiler]was still not working and did try a few things:

wireshark does not give me any broadcast on udp.port = 1900 from volumio (bubbleserver, minimserver, android, w10,… everthing else shows up, be it wired or wireless)

volumio.log gives me: - info: Upmpdcli Daemon Started

I added

logfilename = /var/log/upmpdcli.log loglevel = 4 upnpiface = wlan0
to /etc/upmpdcli.conf
however no logfile is written!

> ps aux | grep upmp volumio 932 0.1 0.6 92316 6220 ? Ssl 12:55 0:01 /usr/bin/upmpdcli -c /volumio/app/plugins/audio_interface/upnp/upmpdcli.conf

ok, no wonder no log file was written, upmpdcli uses another conf file, however i cannot edit this conf file, it will be reset on every startup/reboot.

if I startup upmpdcli manually via upmpdcli -D -c /etc/upmpdcli.conf the logfile is written, but still no broadcast on the network.
also tried to use upnpip instead of upnpiface but no change.

Then I moved wireshark from the 5Ghz (from which broadcast to the wired network segment worked perfectly) to the 2.4Ghz wireless network (to which the raspi is connected too; both networks from the same WLAN AP (a zyxel NBG6716 in AP mode) and voila here are the broadcasts.[/spoiler]
TL;DR: restarted WLAN Access Point -> everything seems to work…
I will post a follow up here if it works now consistently.

[1] #p9031

sorry for bumping, I just have one question: How can I edit the upmpdcli config if the config file (/volumio/app/plugins/audio_interface/upnp/upmpdcli.conf) resets after ever reboot

this file should be in

cd /etc

then you can

sudo nano upmpdcli.conf

*the one you mentioned is “upmpdcli.conf.tmpl”