Update from 2.502 to 2.513 not working

Hi all,

My Volumio installation (2.502 on R-Pi 3) won’t update to the new 2.513. It goes to 1% and stalls there indefinitely. I just tried with a Zero W in the same network, and that worked fine.
In the logs I see this constantly popping up, but no idea what it is/how to solve it (full log here: logs.volumio.org/volumio/1FvTdSH.html)

Dec 10 20:44:32 picassette volumio[1014]: Discovery: ecc TypeError: argument 8 must be an integer (port) Dec 10 20:44:32 picassette volumio[1014]: Discovery: StartAdv! false Dec 10 20:44:32 picassette volumio[1014]: Discovery: Started advertising... picassette - false

Any ideas? The 2.502 was freshly installed very recently, not looking forward to doing that again if possible.

Hello, I had a similar problem, although my upgrade appeared to stop at around 40%. I tried a restart and it seems that the reported halting of the upgrade was incorrect. On restart, everything worked as normal.

Good Luck.

I already tried a few restarts, no luck. On the first two restarts the GUI would not load anymore, although I could connect via SSH. After a full shutdown, wait, reboot, the everything worked fine again, except for the updating. The same log entries kept on popping up.


same here installation halts at 18%
I use Rasbarry whith 4 GB SD card

Actualy the reason I upgraded to 2.501 was because of my previous sd card was giving issues
Now after this upgade same issue. updates seem to halt
I was able to install youtube plugin.

I have reported 3 issues since 2.502
very dissappointed with this over all upgrade (whish I stayed on 2.4)

I installed RuneAudio beta 3 and installation was flawless, NAS cifs mount worked instantly with guest enabled
So there must be something wrong in the Volumio update