[Solved] No WiFi RALINK 148f:7601

Hi, I ordered a couple of cheap wifi dongles from dx.com as I have had a couple of the same ones (or so I thought) previously. Both times I’ve ordered SKU.252716. These new ones doesn’t appear under iwconfig, only lo and eth0. Lsusb gives Bus 001 Device 005: ID 148f:7601 Ralink Technology, Corp.

I am pretty sure the old ones were Ralink as well, but the fact that it is not named “wifi adapter” or something along those lines makes me believe they miss drivers, hence not being the same as the ones I ordered last time as they work just fine out of the box.
So my questions are; is it an easy way to add the drivers to make these work or is it simply easier to just buy new ones?

not sure but your dongle seems to contain a RT2870 chip. Drivers seems not to be included in Volumio. If so, try this : gowthamgowtham.blogspot.fr/2013/ … er-in.html
and tell us !

Hi, this worked a charm! Thank you so much for the link! Just remember to use the right files for the right versions. I had done rpi-update so had to downgrade to be able to use the precompiled kernels.

Mad e-props!

Ok, just a sidenote… The issue is resolved but I just noticed I lost connection to volumio.local and I can’t find it in “networks” anymore. Tried to ssh the last known ip address with no luck. Music is still playing and it did not reboot at any time… Not sure if this has anything to do with it but this has not occured when using ethernet or any other times I’ve used volumio.

Hi, Could you help me get this dongle to work on Volume 1.5 ? I followed your suggestions but they don’t seem to work on my RasPI B with Volume 1.5

thx !!

I’ve posted a link https://volumio.org/forum/wifi-dongle-7601-ralink-help-please-t2559.html before I saw your post

Added the source code. could someone compile this for volumio 1.5 ? thank’s
mt7610u_wifi_sta_v3002_dpo_20130916.tar.bz2 (1.25 MB)