[Solved] NAS - directories but no files ?


on a Raspberry Pi B running 1.4 ;
my NAS mount seems ok, as it has the green check (SMB/CIFS with default mount flags ; ro,dir_mode=0777,file_mode=0777).

I can browse and see the directories of the NAS, but no file.
Could anybody advise on what I did wrong ?

Should I wait longer for the update ? (have already been waiting for 5 hours …)


Can you try it with only one folder which contains only <100 music files?

Thanks for your reply.

Following your advice,

I had the following ;
// Music/Music/

changed for ;
// Music/Music/Ben Harper/2000-Live

in order to only have 1 folder and 10 mp3 files

get the green check for the mount and can see the NAS in the browsing menu, but still empty ; no mp3 file visible
only a sort of directory “.AppleDouble”

Also, when I look at volumio on the network via my laptop, I can see ;

NAS Music
USB Music

and under NAS Music, I can see the folder and the 10 mp3 files

any idea why I can’t see the files in the web UI ?


Can you check with a javascript console in your browser (like firebug for firefox, for instance), if you get some errors when you refresh the webui and browse in NAS folder?

And also: can you connect to your device and check the content of /var/lib/mpd/music ?

Thank you for your advice Jotak. I was trying what you suggested and thought about trying on an other ethernet drive on my network. I copied my music folder and changed the mount on Volumio. It is still updating (70GB), but it seems to work as I can see files now in the browse page under NAS.

don’t know if that’s because of a config of the ethernet drive itself, but for the record, I had the issue on a 2T Western Digital MyBookWorld, and the issue went away just by transferring the files to a newer 2T Western Digital MyCloud.

It hasn’t solved the original issue, but it works for me and that’s enough for me.
Thank you very much for the support