Run out of space, so cloned to bigger SD card. Cannot expand the partition

I like to have all the music files on the SD card, but ran out of space. So I cloned the image to a bigger SD card, using Win32 Diskimager. The SD card starts volumio2, but I do not see the full size under “overlay.”

raspi-config does not work because the command not found. What should I do? I do not want to copy all my music files again onto this sd card. Just to copy the new mp3 files.

You can install raspi-config

Pretty sure it’s “sudo apt-get install raspi-config” (without the ")

Obviously you’ll need to ssh into the Pi first

Try the following and reboot

touch /boot/resize-volumio-datapart

Thanks to both of you! But which one will resize “overlay?” I don’t want to have it create another partition or resize other partition…

This is what the above flag does if you are curious…

This worked! Thank you.

HI everyone,

I am an old volumio user, therefore most of this forum is chinese to me! I did the same as stingray777, ie: ran out of space on the original 8mb sd card that came with my volumio pi. Therefore, I copied the image and mounted a new 256Gb SD card.

The volumio program is working fine, the raspi boots well and everything works. But I do not get more space thant before! Can anyone help me in simple terms on how to be able to use the additional storage?!

I installed putty, have SSH enabled but when I type touch /boot/resize-volumio-datapart it does nothing at all…

thanks for you kink help!

you have to reboot after that to be applied

I did reboot, but nothing happens:

volumio@volumio:~$ touch /boot/resize-volumio-datapart
volumio@volumio:~$ reboot

still no more space on sd card…

Hi Fabricelewis,

Not sure how fluent in Linux you are. But with a Live Linux DVD or USB, you should be able to use a graphical program like Gparted to increase the Volumio partition.

It sounds like you increased the storage, but just copied the data ‘as is’ to a large SD memory card. The disk partition sizes would still be the same as the old SD card and need to be expanded.

well, the signal file /boot/resize-volumio-datapart is there to tell volumio init to resize the data partition and claim the rest of the disk.
You should not have to use any other tool (though this would not harm).
If the signal file is still there after a reboot, then the resize was not done.

Make sure the file is there, then reboot.
After that, go to your browser and type http://volumio.local/dev (or instead of volumio.local the ip address of your pi).
You get a window where you can request a log file ( the first one, not the bottom). Press that button and after a few seconds you get a link echoed in the field next to it.
Copy the link and post it here, perhaps the bootlog will show the problem.