Raspberry Pi 4 8GB - cannot install - "This board requires newer software"

Have attached screenshot, hopefully can be viewed.

Trying to install Volumio (latest available image) on a Raspberry Pi 4b 8GB board, which also has a Pirate Audio Line Out DAC attached.

Any help appreciated or pointers as to what I can do (if anything) to get Volumio installed myself, thanks all.

Alright, got a little bit further. It seems the firmware is outdated.

so I got to figure out how to get that latest on the volumio image to boot it proper for the pi4 8GB model.

I ran into the same issue. Even installing the latest bootloader (2020-06-15) didn’t help.

Since the latest 32-bit Raspberry Pi OS (2020-05-27) boots just fine on the Pi 4 8GB board, I’m tempted to copy the firmware & kernel files off the boot partition of an SD card loaded with this OS, to put into my Volumio SD card. Not sure if this alone would be sufficient, though.

1 Like

This is a known issue and being looked into:

You could use the beta buster images (Volumio Debian Buster Beta - Raspi images debugging), but be aware it doesn’t have the any of the myVolumio features!


Thanks buddy. Have that all up and running now on the Pi 4 8gb and outputting audio on the Pirate Audio Line Out DAC (set as hifiberry dac).

No display on the DAC though. I’ll search around see if I can pull up anything to help get that going now.

Excellent though, delighted to get Volumio running on the Pi4, thank you.

Thanks, @ashthespy!

Got the latest Volumio Debian Buster Beta up and running, and audio over HDMI is functional. However, I noticed any USB devices plugged into the Pi 4 USB 3.0 or 2.0 ports are not detected by the OS. This includes my Logitech USB dongle for wireless keyboard and my KEF X300A speakers. Volumio thus fails to list the X300A as a playback option.

I’m keeping my fingers crossed that Debian Buster will eventually catch up to supporting the VL805 USB 3.0 host controller on the Pi 4.

Hi, just wanted to update this post and say that I’ve managed to get the normal Volumio pi distribution to work with the Raspberry Pi 4b 8gb (revision 1.4).

The problem was the .elf and .dat files in the boot folder of the Volumio were out of date for the Pi4 8gb.

What I had to do was boot up with the beta 64bit RasPi image from https://downloads.raspberrypi.org/raspios_arm64/images/raspios_arm64-2020-05-28/2020-05-27-raspios-buster-arm64.zip

Then update the boot files on the Pi using the usual method from a terminal (or ssh).
For some reason the Pi4 wouldn’t update the files on anything but that 64bit beta image.

Anyway, did that then copied the .elf and .dat files from that raspi 64bit distribution and copied them onto the boot folder of the Volumio distribution’s card, overwriting anything already there, boot up with that and then everything worked perfectly.

Still can’t get the screen working on the Pirate Audio LineOut DAC but it is at least outputting sound so all is good.

Thanks for the help. The debian buster beta also worked well btw but nice to be using the default distribution now.


@oXo, I just confirmed your findings, and got latest Volumio 2.806 up and running with my Pi 4b 8GB, after transplanting .elf and .dat files from beta 64-bit Raspberry Pi OS into the boot partition of the Volumio SD card.

Thanks for sharing this solution!

1 Like

it would be better to get a full 64bit volumio instead of 64bit parts in a 32bit system 32bit still could nog get the full potential of 64bit and the full memory 8gb instead of a 3,25 of 8 gig


I’m not very familiar with the Debian Buster image but I read on this forum that Volumio will survive an update with apt (at this point).

I found this page (and many more) by searching for vl805 usb


There are instructions there to update the firmware for the Pi 4. If I were you, I’d try it! Back up your information and go for it.

It runs fine though on a Pi Zw with 512mb RAM. Even 4gb is overkill for Volumio.

Only reason I mention the copying the .elf and .dat files from the 64bit RasPi distribution is because for whatever reason, some bug with RasPi images I guess, the files won’t or at least didn’t update on the Pi4 8Gb using the 32 bit RasPi image distribution when I was trying and the same for others.

Otherwise the 64bit version doesn’t matter in regard Volumio. Like I said, it runs fine on just a basic Pi Zw with 512Mb of RAM - it’s what I’m currently using myself as the Pi 4 8Gb is wasted running Volumio (was all I had at the time though when making this post initially).

@oXo @scan80269 can some one create a image of that ?
and oxo 64 bit is really fast in response with a ssd next to it so yes it makes a big diffrence
does your pi zero handle that? no you only can boot from sd so if you didnn’t test it don’t speak about it…
btw 3.25 gig under 32bit or 8 gig under 64bit makes it faster again… and running pi instead of 1500 to 2000
makes it faster to …zram gives it again a boost…

2GB of RAM is already more that enough to run Volumio. Moving to 64bit to make use of 8GB of RAM will not make your system faster or smoother

no you have a ssd on it i guess and have the rest on it?

I’m sorry but I don’t understand what you mean

@dvo It doesn’t need to be faster buddy, it’s running great on a Pi Zw with 512Mb RAM. There’s no need for Volumio to use 8Gb RAM. Sure it would be nice to have 64bit version but really there is no need at the moment as like I said, it runs perfectly fine even on old Pi Zw and 512Mb RAM.

I think I could prob create an image with the 64bit bootfiles but it is really easy to do yourself, to just copy over the .elf and .dat files after you upgrade your Pi4’s boot with the 64bit RasPi image first.

I’m sure Volumio will release and updated image themselves soon with updated .elf and .dat and whatever other improvements.

I don’t run an SSD with the Pi Zw though no. I have all my music shared out via 8TB drive on the network via Enigma2/Dreambox DM900 Satellite linux box.

I have tried SSD drive with Pi4 8GB via USB 3 and I didn’t think it was that great. It was only a 240Gb SSD though and my music collection is maybe close to 6TB so not much room on the SSD plus it works fine over wifi and no extra interference in sound.

Bluetooth is rubbish on Pi Zw but that is not Volumio’s fault.

I also cannot use the Volumio app on Android with Volumio on the Pi Zw, keeps popping up a SSL error, so I just use a web browser on mobile to control it. That is the only drawback I see from changing to Pi Zw from Pi 4 8GB.

mine is running that already … but have no normal install btw every ssd makes a diffence there is a list of
ssd’s that’s running high speed and you have standaard arround the 400 / 540 samsung… a 3.1 ssd runs really fast… there is a list what’s fast and what is …slow ssd …btw dreambox is nice :slight_smile:

btw did you see this?or this? you will find them with diffent scores… and usb 3.0 and 3.1 makes a big diffence… if you changing to pi 4 8gig you need 64bit…

Is it fixed/officially supported now?

Pardon me for jumping in here, but I felt it important to mention a very important fact about the Raspberry Pi:

The boot files and folders are NOT interchangeable!

You WILL run into strange and bizarre problems if you mix-and-match boot files.

The best solution is to find an image that works out of the box.

You MIGHT be able to get things squared away by copying the files, and then doing a full update, including a kernel update, that will update all the files so that they are consistent with the entire package.

Fair warning people. . .

just install the latest 3.xx version and your good to go.

1 Like