[PLUGIN] YouTube Music

hi! I haven’t used Volumio for a week or two, and now the ytm plugin doesn’t work. It’s active, and logged in, but all operations bring up a “no result” toaster
I tried to log out, reboot, remove the plugin, and install the latest version, or 1.0.1, but none helped

the yt2 plugin works well, the only diff I see is that for yt2 I can select the correct locality anf language, for the ytm it is hard coded to US/English

Current (beta) version is 1.02.
That might fix it for you.


hmmm… looks like it works again, if the volumio language is set to English

thanks, but no. 1.0.2 is shown as stable, bytheway

v1.0.2 is now stable.

What do you mean? You should be able to change to another language and it should still work.


If that is the order you did, i.e. reboot → remove plugin → install latest version, then it will not work because Volumio would still be loading the old version. It has to be remove plugin → reboot → install latest version.

Maybe this helped, I didn’t think the order was important.
Now v1.0.2 works well in any language,

Thanks a lot!

Fixed, works beautifully! A million thank you to @patrickkfkan

Hi, First, thanks to Patrick for maintaining this plugin! I am casting YT Music to my Volumio and adding songs to a new playlist on Volumio. First the playlist itself wouldn’t show up untilI I restarted the Volumio app on my phone. Now that playlist comes up but there are no tracks displaying in it, despite having added several. Is this a bug or missing feature in the plugin or is this a universal problem with Volumio? I seem to remember something similar with tracks from Spotify and my NAS not displaying on the playlist.

Volumio v3.631 on rPi 4B
YT Music 1.0.2 / YT cast 1.0.6

It’s a missing feature, because the idea is to control most things through the YT / YT Music app. So instead of adding songs to a Volumio playlist, I would expect them to be added to a YT playlist.

I see. One of the coolest features to me is being able to mix sources. But it’s nota big deal. Thanks for clarifying that.

Hello guys, could you please help me with settings in YouTube Music? The settings screen is always empty, so I couldn’t even log in to my youTube account. The version of plugin is 1.0.2, the volumio rev is 3.701.

Thank you in advance!

Please provide logs.

Hello Patrick, these are the logs after pressing on button Settings:

info: CoreCommandRouter::executeOnPlugin: system , getPrivacySettings
info: CALLMETHOD: system_controller my_volumio retreiveBackendEventStates undefined
info: CoreCommandRouter::executeOnPlugin: my_volumio , retreiveBackendEventStates
info: Received Get System Version
info: CoreCommandRouter::executeOnPlugin: system , getSystemVersion
info: Received Get System Info
info: CoreCommandRouter::executeOnPlugin: system , getSystemInfo
info: CoreCommandRouter::executeOnPlugin: volumiodiscovery , getThisDevice
info: Discovery: Getting this device information
info: CoreCommandRouter::volumioGetState
info: CorePlayQueue::getTrack 0
info: CoreCommandRouter::executeOnPlugin: network , getCachedIPAddresses
info: CoreCommandRouter::getUIConfigOnPlugin

I need logs covering the following actions:

  1. Disable plugin
  2. Enable plugin
  3. Enter plugin settings

Is Volumio version 3.701 a beta version? Does it work on latest stable (v3.695)?

Hello Patrick, I tried different version, now version 3.661 is set up, so the logs are the next:

Starting Live Log…
process exited with code nullinfo: CoreCommandRouter::volumioRemoveToBrowseSourcesYouTube Music
info: CoreCommandRouter::executeOnPlugin: my_music , getDisabledSources
Cannot find translation for source YouTube2
info: Disabling plugin ytmusic
info: Done.
info: CALLMETHOD: system_controller system enableLiveLog true
info: CoreCommandRouter::executeOnPlugin: system , enableLiveLog
info: Launching a new LiveLog session
info: Killing previous LiveLog session
info: Live Log process terminated: null
info: Enabling plugin ytmusic
info: Loading plugin “ytmusic”…
info: PLUGIN START: ytmusic
info: CoreCommandRouter::volumioAddToBrowseSources[object Object]
info: [1717442978413] CoreMusicLibrary::Adding element YouTube Music
info: CoreCommandRouter::executeOnPlugin: my_music , getDisabledSources
Cannot find translation for source YouTube2
Cannot find translation for source YouTube Music
info: Done.
info: CoreCommandRouter::getUIConfigOnPlugin
info: [ytmusic] InnertubeLoader: creating Innertube instance…
(node:838) UnhandledPromiseRejectionWarning: TypeError: Cannot read property ‘replace’ of undefined
at Function. (/data/plugins/music_service/ytmusic/node_modules/volumio-youtubei.js/bundle/node.cjs:22437:48)
at Generator.next ()
at /data/plugins/music_service/ytmusic/node_modules/volumio-youtubei.js/bundle/node.cjs:233:73
at new Promise ()
at __awaiter (/data/plugins/music_service/ytmusic/node_modules/volumio-youtubei.js/bundle/node.cjs:212:16)
at Function._Session_retrieveSessionData (/data/plugins/music_service/ytmusic/node_modules/volumio-youtubei.js/bundle/node.cjs:22424:10)
at Function. (/data/plugins/music_service/ytmusic/node_modules/volumio-youtubei.js/bundle/node.cjs:22357:99)
at Generator.next ()
at /data/plugins/music_service/ytmusic/node_modules/volumio-youtubei.js/bundle/node.cjs:233:73
at new Promise ()
at __awaiter (/data/plugins/music_service/ytmusic/node_modules/volumio-youtubei.js/bundle/node.cjs:212:16)
at Function.getSessionData (/data/plugins/music_service/ytmusic/node_modules/volumio-youtubei.js/bundle/node.cjs:22352:12)
at Function. (/data/plugins/music_service/ytmusic/node_modules/volumio-youtubei.js/bundle/node.cjs:22347:78)
at Generator.next ()
at /data/plugins/music_service/ytmusic/node_modules/volumio-youtubei.js/bundle/node.cjs:233:73
at new Promise ()
(Use node --trace-warnings ... to show where the warning was created)
(node:838) UnhandledPromiseRejectionWarning: Unhandled promise rejection. This error originated either by throwing inside of an async function without a catch block, or by rejecting a promise which was not handled with .catch(). To terminate the node process on unhandled promise rejection, use the CLI flag --unhandled-rejections=strict (see Command-line API | Node.js v22.2.0 Documentation). (rejection id: 3)
(node:838) [DEP0018] DeprecationWarning: Unhandled promise rejections are deprecated. In the future, promise rejections that are not handled will terminate the Node.js process with a non-zero exit code.

Thank you in advance!

It has been promoted to an official release today.

1 Like

Seems to be this problem:

This is a system-level bug with Node / ICU library. You should be able to work around it by changing your Timezone (Volumio settings → System) to something else like “UTC”.

Dear Patrick, thank you for your support! Now it works as expected :metal:

I just reinstalled v.1.0.2, seems to work with the youtube music (android) app now :sunglasses:.

So, no need for test mode for any plugins or player now?

Thanks for the good work :slight_smile:
When I search for an artist and scroll down, the artist is not listed under artists, it is as if it shows number 2 and onwards. If I click show all, the artist is listed first. If I’m not logged in to YTmusic it shows 160kbps on the screen but if I’m logged in with my premium YTmusic it doesn’t show anything?

Regards Kent