[PLUGIN] Touch Display

Open “/boot/userconfig.txt” with nano

nano /boot/userconfig.txt

Comment out your current display related entries by adding # at the beginning of each line so it looks like

#hdmi_timings=320 0 80 16 32 1480 0 16 4 12 0 0 0 60 0 42000000 3

Then add


and hit Ctrl+x, y and Enter to save the modification and close nano.

If you have also changed the “/boot/config.txt” file, undo these changes as well. They will be overwritten with the next Volumio update anyway.

Connecting to Volumio via SSH is described here.


Hey Andy,

With the problematic screen connected to the HDMI0 port (next to the USB-C) please post the content of the /var/log/Xorg.0.log from fresh start. This would show modeset and perhaps failing edid.

Kind Regards,

Hi @nerd , I just talked to my friend and he said the problem was the HDMI cable. He said it’s working now. I guess you need a good HDMI cable to make it work for the Raspberry Pi. How weird that the bad cable worked with Windows/PC but not Volumio/RPi.

By the way, I just want to confirm and second @dewen that the official 3.703 cannot perform an OTA update to version 3.733.

Updating to V3.733 is working again

1 Like

ook, we seem to be making some progress, commenting out the current display parameters from userconfig.txt and adding in the dtoverlay parameters yeilded good news and some bad news.

The screen saver now functions as intended, BUT their is a wide black band around the borders of the screen producing a much smaller and unsightly image.
What to do??

I experimented with including both entries and have success, Screen saver now works and display now fills the screen!!

Continuing the discussion from [PLUGIN] Touch Display:

I’m new to Volumio and troubled by my recently bought display - Waveshare 11.9 HDMI in a casing via HDMI on a rpi 4b. After several tries and useful entries from the forum I still have the problem that the picture is off (see attached photo) - so it is not filling the screen. On the right side is a black gap and on the left side is some stuff missing from the plugin.

How can I change the position of the plugin/ picture?

Thanks in advance!

please provide the output of:
cat /boot/config.txt
cat /boot/userconfig.txt

Reference link to your waveshare screen at https://www.waveshare.com/

Thanks for putting ht post into the right spot - sorry for the extra effort.

Here are the requested txts.




initramfs volumio.initrd
include volumioconfig.txt
include userconfig.txt


Touch Display rotation setting below: do not alter


hdmi_timings=320 0 80 16 32 1480 0 16 4 12 0 0 0 60 0 42000000 3


You wrote that the display in question is connected via HDMI, but you (also) have dtoverlay=vc4-kms-dsi-waveshare-panel,11_9_inch,rotation=270 in “/boot/useconfig.txt”. So just for clarification: Is it an HDMI or DSI display?

It is an HDMI touch display.

Try removing


from “/boot/userconfig.txt”.

Thanks for the quick reply - I’m going to try it when I’m home again from work.

You might also try the following settings from Waveshare’s wiki (for the touch screen variant of the 11.9" HDMI display - don’t know if this is relevant):

hdmi_timings=320 0 100 32 230 1480 0 10 10 10 0 0 0 60 0 59400000 0

I had had these entries before, but found some different settings in the community (the ones that are and in the “/boot/useconfig.txt” now). The new entries didn’t change anything with my problem so I left the “new” ones in.

I’m going to try both hints anyway.

Thank you.

Please provide a link to your LCD from Waveshare. It seems their are a couple of them with different settings.

Thank you so much for your support - it is working properly now!!!

Just for the record: What settings are you now using in “/boot/userconfig.txt”?

I am running the Free version of volumio, and have successfully enabled the OLED with the spectrum.
I would like to use the touchscreen 3.5 display, but when loading the plugin, it says that I cant use it if HDMI is an option…so, how do I do this? Sorry for Noob question