[PLUGIN] Touch Display


Due to corruption of SD-card I needed to install everything from scratch. This is the first time this install gives me a headache.
Installation keeps failing and now even the rollback gets stuck on:
After a few reboots and uninstall, it got removed on the 3rd attempt.

Only weird things I see in the logs, see below, even though the sites are accessible and network is available and stable.

info: Err:3 http://raspbian.raspberrypi.org/raspbian buster/main armhf fonts-arphic-ukai all 0.2.20080216.2-4
info:   Could not connect to raspbian.raspberrypi.org:80 (, connection timed out [IP: 80]

E: Failed to fetch http://raspbian.raspberrypi.org/raspbian/pool/main/f/fonts-arphic-ukai/fonts-arphic-ukai_0.2.20080216.2-4_all.deb  Could not connect to raspbian.raspberrypi.org:80 (, connection timed out [IP: 80]
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

HW: rPi4-8GB, rev 1.4
SW: Volumio-3.378-2022-09-30-pi.img
Plugin: V3.3.5 (stable)


On the 5th attempt it finally got installed…


These timeouts seem to occur from time to time and - as you experienced yourself - vanish after some time. It’s hard to say what causes them. ATM I don’t consider the timeouts to be related to the plugin itself as the plugin does not even provide the link for the repository (I think the URL is derived from the settings in Volumio’s “/etc/apt/sources.list” file).

Yeah, thought so.
I just mentioned it, in case other people run into the same issue.
For the Dutch peeps, As Barry Stevens always said: " Vooral doorgaan"

1 Like

Hahaha ja die Barry :grin:doorgaan

Hello. I read everything from the very beginning. Confused. I have the latest Volumio, Raspberry Pi 4 and a 3.5inch RPI 480x 320 XPT2046 screen. The plugin is installed, but the screen does not work. How can I make it work?

Did you add an overlay to the userconfig.txt?
sudo nano /boot/userconfig.txt
then add this line to the bottom
give Ctrl+X then save and exit.

Give the command:
sudo reboot

No, I didn’t do anything through ssh at all. What commands do I need to give from start to finish? Thanks for the answer. I am very bad at this topic.


I’ve done everything. Screen is black after reboot.

let’s wait for @gvolt comes online, he’s the master on this.

Thank you. I’m trying now 3.5 inch GPIO display - Black Screen - #4 by gvolt ,but no result.

Thank you. Everything worked according to the instructions.

So it’s solved now?


Hello again. The problem was solved yesterday, but not completely: the screen does not respond to clicks, in any way. Tell me, what could be?

Touch part is not yet installed :stuck_out_tongue: and / or configured :wink: @gvolt could you…
In the touch display plugin you can enable a pointer,
then you could see if there is a responce when you press on the screen.

turned on, zero reaction

Do you have a link to the seller of your screen brand ?
Then we could find the info of the board and look what for the parts
You need for the install of the touch.

No, he had been lying idle for a long time…

3.5 has multiple versions of it is there any info on the board ?