[PLUGIN] Now Playing

asking things about peppy meter here at the now playing plugin posts,
that will result in no anwser most of the time.

it’s like asking by the baker, how he has to cook the pork from the Butcher.

DVO, I know that English is not my primary language but I thought I was clear enough: it is not a question about PeppyMeter as this is completely OT here, it is a question about the conformation that if using Now Playing I’m allowed to use a 2nd touchscreen to show any other plugin output or Volumio’s own UI (the referring to PeppyMeter is completely and only informational, just to gave an idea of what I’d like to see on the 2nd screen).

1 Like

btw i’m dutch so english is my second lang too :wink:

both plugin’s can use a second screen one is the UI and one is the screensaver screen.
most of the time 1 is a dsi screen connected to the pi and one connected on the hdmi.

@AngeloMM

As far as I know, it will support only one display. Some examples that passed by, were opening “Now Playing” via a url on a 2nd screen.
As in your example, peppy is a screensaver, which will automatically overwrite the screen where you run it on.
Hope this answer your question.

Thank you Wheaten, yes that answer my question, not in the way I was hoping for but at least is a confirm.
I’ll look for another way to have two screen running independently, both of them connected to the RPi (no network involved).
Thank you again!

Angelo

Hi,

I’m configuring the plugin and I run into three issues (could find here how to solve it).

1 - whatever I put on the server IP it always returns and tries to open in 127.0.0.1:

2 - I’ve coordinates inserted but can’t get any weather info

3 - I’ve generated and inserted genius token but can’t get any info. It just keeps waiting for info (arrow rotating).

Any help, please? :slight_smile:

Do you have anything like pihole in your network?

How to have the hour in 24h format?

1 Like

Thanks Wheaten,

No (don’t know what that is…) LOL

I can reach from browser using volumio.local:4004 but can get the plugin configured with any other IP so when I press “Open Preview” it goes to 127.0.0.1:4004 (and of course it gives a server not found).

Idle screen

Thanks… i did not see the Time Format options… :slight_smile:

This is a very specific problem that’s not the fault of the plugin, and it will apply to practically no one. Just posting it for when that one person in the world has the same problem in five years, the solution will be here.

Problem: When trying to add the Now Playing webpage to Yodeck digital signage you get a blank white screen.

Solution: Add Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:109.0) Gecko/20100101 Firefox/119.0 as the User Agent in Yodeck’s Media/Web Page settings for the Now Playing page your.ip:4004

I must admit this took me entirely too long to figure out. It’s been working like a champ ever since though!

1 Like

No ideas?
:wink:

why do you think that there is standing read only ?
btw why would you wanna change it …it’s always local host aka 127.0.0.1

There should not be any other ip. The now playing runs on the local host so ip 127.0.0.1 is more then valid.

I have question about problem with album Cover pics on the Now Playing screen.

It is no matter which version on Volumio I use, if it play playlist from beginning to the end, album covers are ok. If I choose song from playlist or use seek bar… next song shows wrong album cover (from past song). In this situation if I use peppymeter I have wrong album cover too and counter shows still 00:00. This problem was solved by someone??

The problem he is trying to get over is when you click the “preview” button, its passing over the loopback (local host) IP to the remote devices browser.
The remote device is then looking at itself for the hosts broadcast so will not find it.

The preview IP address its passing to the remote device ideally needs to be the IP address of the host, not the hosts loopback address.

1 Like

Then I am clueless, for me it’s the other way around.
I can’t get it to 127.0.0.1 mine is sticked to the fixed IP I gave my device (v0.3.8)

Have you tried reinstalling the plugin?

Yeah, I remember the earlier versions were like that.
latest is V 0.5.4 and this is a fresh install.

I am personally not bothered that the preview doesnt work as I have allways used the device im setting up to view how the changes happen.
Just trying to help explain better what the issue is. :slight_smile:

I’ll try to reinstall the plugin again. :wink: