[PLUGIN] NanoSound CD plugin

for volumio 3 ?

yes :wink:

Hi Aiello,
sorry to bother you, but would you be so kind and tell the steps you took to make cd play work a little more detailed? I installed nanosoundcd and sg3-utils but this changed nothing for my install.
Thanks a lot!

you don’t need to install nanosound…in sg3-utils, the menu to the cd is only displayed when a cd is inserted…

I tried installing via method 2 and says Tinkerboard not supported. So I assumed .Volumio 3 is not supported.
I have the A&K CdRipper Mkii and was trying to see if there would be a difference in sound. Oh well, whenever it’s updated I’ll try.
Just ran the scrip again with a cd in my cd player, didn’t install because it was already installed.

it now shows in my installed plugins after restart…

to be clear, I used Aiello’s commands…

should nanosound working with Volumio 3.378_x86?

I installed because I want to playback cd but nothing is loading in Nanosound cd.

nanosoundcd_web.service - NanoSound CD Web Service
Loaded: loaded (/lib/systemd/system/nanosoundcd_web.service; enabled; vendor preset: enabled)
Active: failed (Result: exit-code) since Wed 2022-11-02 15:42:12 UTC; 1min 30s ago
Main PID: 1530 (code=exited, status=1/FAILURE)

hi @Aiello ,

I am using commands you shared for getting external usb cd player in Volumio 3.
I haven’t installed any plugin, as you mentioned is not necessary, but even after restart and with a cd insterted in the player, I cannot see any cd menu.
External usb cd player is connected to the board over USB, i am also using an external power supply for the cd player to be sure it has enough power.

Is there something I am missing?

Thank you

Hi,

is there way to use an old CD rom player with digital out?

thanks
Jem

Hello : mcarr6

Do you mean you can use nanosound CD on volumio 3 ?
Could you describe more detail on how to do it ?

I use Asus Tinkerboard with Volumio 2 and nanosound CD for a period and it works well.
2 days ago I upgrade to Volumio 3 and found the plugin not support.
So I downgrade to Volumio 2, but I can not install the nanosound CD plugin,
the volumio plugin install said
“Sorry, Tinkerboard is not supported via repository. Please visit NanoSound CD Plugin for Volumio – Support – Nanomesher for more detail”
I also tried the SSH script method, but there seems some 404 missing file error.

Is there any method to re-install nanosound CD on tinkerboard/volumio 2 ?
or can anyone send the pre-config image with volumio 2 and nanosound CD for tinker board ?

thank you very much !!!