[PLUGIN] Music Services Shield

Tried many settings. 0-2 is just too much for a RPI 3b even with priority switched off. Now at 2-3 still without priority for 2 hours without glitches. Seems to work. Serious testing would be after my 3 weeks vacation. Thanks :+1:

Edit: priority at 80. No problems. System is fast

Thanks for the update. That’s interesting. I’m running with a Tinkerboard S with 0-2 but priority disabled.

Running at 90% priority with 1-2 now, still no problems in past 2 hours. I will test further and tell you what the sweetspot for a Pi 3b based streamer (Magna Mano Ultra MKII in my case) is.

1 Like

I compared priority of 40 for mpd Vs 60, 70, 80, 99. The reason to pick 40 is that places the priority of the parent mpd tasks lower than the IO tasks, which mpd fixes at 50.

I prefer this lower priority (40)

However I prefer to leave the priority unaltered for Spotify connect

If you are interested in adding Shairport-sync to the Music Shield, track the progress of this issue:

1 Like

If you are interested in adding Spotify (rather than Spotify Connect) to the Music Shield, track the progress of this issue:

Hi Pete, I noticed that the plug-in is not in the official download section anymore. I am still very happy with it. Will official support come back?

The Volumio team removed it because they found a problem in the start-up that affected some Raspberry Pi builds. I have made their recommended changes and have a merge request pending. Once the Volumio team is happy with the changes they will publish the plugin again.

1 Like

No update or boot problem on my RPI 3b+ based streamer with the ‘‘old’’ version.

Version 1.2.2 has been merged in, so hopefully it will be published on the plugin OTA service soon

2 Likes

FYI:
Updated to newest version but the system states nothing has changed:
Reading state information…
cpuset is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 27 not upgraded.
Installatie afronden (done)
Update geslaagd (succeeded)

I uninstalled and installed again to be sure I’ve got the latest

1 Like

Thanks Vennesch. That makes sense as the only change was to prevent any error that may occur on start-up from affecting the rest of Volumio.

Great! I had it working again. Now on Volumio Buster beta. Are you planning to make it a available for version 3.xx?

Enjoy your Sunday

I’m not yet sure what changes are necessary to make the plug-in work for Volumio 3. Once I know, I’d like to update it

Everything should be the same for this plugin… The service names are the same!

Thanks Ash, that’s good to know. Is there anything I can to to migrate the plugin? Or is this being done by the Volumio team?

2 Likes

I am aware that the Spotify Connect one was automatically migrated, but not really clued in to what is happening for the rest of the plugins in the store.
I believe there are some new tests/procedures for the plugins in place, but not sure what the status is.

@volumio/@mervinio are all current officially available plugins going to be migrated over to the new myVolumio plugin store? Or is this something each dev must choose to do?

1 Like

We are preparing a guide for testing of plugins to V3. Once done, each dev can port his plugins to V3

2 Likes

I have ported it to Volumio 3 and tested it on my environment.

You can track the status of the port here: Test plugin on Volumio 3 · Issue #3 · petecallaghan/volumio-plugins-sources · GitHub

1 Like

Will that really nice plugin run on my Allo Sparky USB Bridge?
I get that response, when i want to get a status:

cset: **> mount of cpuset filesystem failed, do you have permission?