No sound out of HiFi Berry DAC + with Volumio2 (2.799)

it’s weird, it looks like the order of the declarations in cmdline.txt plays a role!

I’m afraid more test is required…

Darmur yours and gvolt’s solution works for the Rapsberry pi 3 B+ with Raspberry pi official touchscreen and Hifiberry DAC +

1 Like

I am indeed running parametric eq.

Here are the plugins I have loaded and their status.

Parametric EQ - ON
System Information - ON
Autoplay - OFF
AutoStart - On
Backup & Restore Data - ON

I won’t be able to try any troubleshooting in the next few hours. Thanks for the prompt attention.


this solution isn’t work for me.

I don’t see a new test-version when I check for updates?

Hi Guys,
there is now a new BETA version (2.801), which adds the fix proposed by DARMUR.

Please update and report results.

NOTE: If you have the simple equalizer plugin or parametric equalizer, please try this:

  • After update, disable both plugins, reboot
  • Enable the plugin, go to its settings, save , reboot
  • Report if that works

If something does not work, please:

  • send log and paste log link here
  • paste output of aplay -l
  • paste output of cat /etc/mpd.conf


After the update the system is unreachable (but with the Piano 2.1 board).
I will try to add a monitor etc. to find out why.

screen says

switch_root: can’t execute ‘/sbin/init’: no such file or directory

edit 2:
Tried from a fresh install on another device (3A+ with USB DAC). Same result.

For me the same, system can not be reached.
Also the way backi s blocked. I have flashed an older version of volumio and this will not work as well.
Could this be caused by the development mode?

I am now in a situation that I can not run anything at all anymore.

Okay, next update. I am alive again with the system. Reason : corrupt micro sd card after flashing.
New cd card and I am up again, but on an older version.

Me too, is it possible that flashing destroys the SD? or is it just a fluke?

Surely the micro SD card isn’t destroyed?
How about reformatting it with the formatting tool from SD Card Org

Then burn the Volumio image to it.

I did the OTA update to 2.801.
Download went through but restart never completed. I let it go overnight (8+hrs) and still going in the am. Couldn’t ssh in to force a restart or shutdown so I power cycled it. Still no restart.
Looks like I’ll have to start over and flash the SD.
Where can I download 2.801 to flash onto SD? I didn’t see it on github.
I might have missed it, I don’t use git very often.

the update of 2.802 works very well, thank you

What I don´t understand: I have 5 raspi 3A+ with hifiberry dac and firmware 2.799 and the issue was only on 1 of them

Updated succesfully to 2.802.
I don’t have a hifiberry, so don’t know if the issue itself is resolved.

Update to 2.802 is working.
I have not added plugins yet.
Will let you know how it goes with Parametric EQ

Great thanks! 802 should be fine (except for hw mixer on IQ Audio DAC, which we are solving)

I’m trying latest beta update 2.802 on a RPi4 (2Gb), proposed fix is applied on cmdline.txt

I don’t know if it’s the expected behavior, but I don’t have any HDMI card and I2S DAC is on card1

volumio@volumio-home:~$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Headphones [bcm2835 Headphones], device 0: bcm2835 Headphones [bcm2835 Headphones]
Subdevices: 8/8
Subdevice #0: subdevice #0
Subdevice #1: subdevice #1
Subdevice #2: subdevice #2
Subdevice #3: subdevice #3
Subdevice #4: subdevice #4
Subdevice #5: subdevice #5
Subdevice #6: subdevice #6
Subdevice #7: subdevice #7
card 1: sndrpihifiberry [snd_rpi_hifiberry_dac], device 0: HifiBerry DAC HiFi pcm5102a-hifi-0 [HifiBerry DAC HiFi pcm5102a-hifi-0]
Subdevices: 0/1
Subdevice #0: subdevice #0

Anyhow, playback works fine disabling I2S DAC and selecting HifiBerry DAC from the list

Even with I2S DAC disabled, I still have the dt-overlay declared in /boot/config.txt

volumio@volumio-home:~$ cat /boot/config.txt
initramfs volumio.initrd

include userconfig.txt

Volumio i2s setting below: do not alter


I have sound with the Parametric EQ plug in settings in effect.
But the volume is fading in and out and there is some clipping.

This is on the Pi4 build with HifiBerry DAC + pro

pi4 HifiBerry DAC + pro Volumio2.802

I have the Parametric EQ working fine after restart.

New observation: I lost sound when I enabled Autoplay.
After disabling Autoplay and Autostart and rebooting all is well.