Multiroom (browser) switching issue with volumio3

I think there is a bug with switching the multiroom devices in volumio3.
What works:
Volumio3 on a Raspberry with a audio dac. Connecting from external device (mobile phone for example) to the webpage. All is fine. You can conntect to the IP of one volumio device and from there you can switch with the “Multiroom” option to all other devices and back to the starting device.
What does not work:
Volumio3 on a Raspberry with a dac and a display. The same thing, but now connecting directly from the raspberry (with the display) to the webpage. This works no problem, but when you switch via “Multiroom” option to another volumio device, this works, but you can never switch back to the starting device (with the display connected, so in fact the local device).
And, maybe a hint: Before switching, you see the pictures of all other multiroom devices, but the local picture is not shown (in the multiroom overview).
So it looks like there is a problem with the local URL or something like that. :thinking:
I think we had the same issue during beta testing, but unfortunately i can not remember exactly.

Edit: Ok, looks like i found the fix which i remember:

But it is installed and does still not work. :man_shrugging:

This problem has been reported for Volumio 2 some time ago. Not sure if it is related to the issue you have linked to.

Uhhh, sounds very similar.
I am pretty sure it has worked on 3.015 after installing libnss-mdns. But it looks like something is broken now in the final.
Do you have such a setup? Can you test it?
It is a fresh install.
Hope it is not a password thing! :grinning:

No, at least that’s for sure :grin:

Yes, it looks like it is the same problem like in volumio2.
Here you can see the missing picture:
And this happens when trying to switch back:
When connecting a keyboard and press “F5”, it reloads the page and it is working!
Unfortunately i only have one device with a display. So i can not test if this happens also on another devices. All other devices are “remote only” devices.

Just tried multiroom on the x86 variant of Volumio version 3.179 (running in a VM). It shows the same behaviour. So it’s not specific to Volumio running on a Pi.

Good to know. :+1:
Are you able to try 3.015 and install libnss-mdns to see if this works?
I am pretty sure this version has worked, but maybe i am wrong. :man_shrugging:

3.015 would have been a very unstable test version from early February this year, we didn’t even have multiroom then.

I am not talking about “Multiroom-Play” i am talking about “Device-Switching”. It is maybe called the same, but i think it are two completely different things.
It looks like a DNS problem or something like that :thinking: For me it looks like the local device can not connect to it self.

Just checked, there is no 3.015, only a 3.014 and 3.016. Did you participate in the very early debugging sessions? If not, than you must be referring to a different version as the early ones were not for the public.

Yes i was beta tester since a long time :wink:
See here: Volumio Debian Buster Beta - Raspi images debugging - #389 by ashthespy

I have removed “libnss-mdns” to disable device browsing. This way my kids can not lockup the device if the klick on another room. :stuck_out_tongue_winking_eye:
But it is of course not really a fix.

Such brute force, love it! :smiley:

You could also try disabling the discovery plugin in plugins.json that is located in /data/configuration/ and restart the node app. (volumio vrestart)

This will likely cause lots of issues the next time you update…

Could be yes, but i need a fix. Otherwise i can boot the devcie every hour :stuck_out_tongue_winking_eye:
I still ask me why this happens only on local devices. Is it a problem of the local browser (chrome)? :thinking:

Disabling the discovery plugin seams not to work. Maybe i made it wrong? :thinking:

Best to ask @volumio how to do it – from the other thread there seems to be some ideas already floating around :slight_smile: