Manually uninstall plugins


I installed AmpSwitch on my Rpi with Pi-Dac+ and Pi-AMP though GUI and I couldn’t get it to work properly. Then it muted my amp and I couldn’t get it to come back on again no matter what I tried - rebooting etc etc.

I tried to uninstall the ampswitch plugin and it wont let me switch off or uninstall (seems to just restart Volumio).

Can anyone help or tell me how to uninstall this plug-in using SSH?



1 Like

Volumio plugins are located under the /data/plugins folder. You should be able to remove the folder of ampswitch there.


1 Like

Sorted, thanks.

dont forget to remove the entry in /data/configuration/plugin.json, and restart. Otherwise you get a message plugin exists when you try to reinstall the plugin.

Out of curiosity - what was the issue with the plugin?

YouTube plugin update failed. Uninstall in client and commandline didn’t work.
This trick did it.

How do you access those folders?

Via SSH from another networked computer. Follow the Volumio manual online to get started then use an FTP client to access. Remember to select SSH in you client when linking.

1 Like

use winscp for those things…

1 Like

or ssh (openssh):wink: … or even the built-in Windows ssh client.

i like the drag and drop function of winscp makes life eazy

Thanks, I had to do a complete reinstall. Plugins failed to uninstall, and nothing was working. I think I can do ssh via the console on Mac.

1 Like

Did this yesterday with a ‘sticky’ RotaryEncoder2 plugin: SSH in Terminal on a Mac and deleting the directory of the plugin. After reboot all problems solved.

1 Like

Or use an FTP software like Cyberduck - gives you a more visual interface.