Lan not working(i219-v, volumio on intel NUC)


I have intel NUC6i5SYK for my music player by using volumio.

BUT, THAT intel lan i219-v don’t working!!!

I had googled about THAT i219-V and i know it can be work after kernel update(maybe 4.X?) and lan driver compile(may be need some code fixing…) in ubuntu system.

But I want to use lan in Volumio!

i also found some posting about i219-v problems in volumio…

Anyway current version don’t working. :frowning:

Please consider i219-v lan problem in Volumio development. Thank you.

Yes that is a known issue for the official x86 version, nothing that can be done about it (the kernel is too old and we decided not to update).
We have a new beta release coming soon, based on Debian stretch, which will use kernel 4.19 LTS.

In the meantime I recommend to try the last dev version
It has a mainline kernel, is very usable and confirmed stable by a number of people, but does not have all the latest bells&whistles (like myVolumio).
Flash the referenced version and give me a short feedback, AFAIK it already supports i219-v.

WoW, it works!

I used volumio-2.416-2018-07-08-x86.img and finally, i can see eth0!

(volumio front GUI did not start automatically, so i connected to Web GUI, anyway)

mp3, flac, dsd64 all music file played well. Thanks again!

Now, i can continue to setting my NUC as music box .


I just tried Volumio 2.779 on Intel NUC7i5BNK.
system doesn’t ser network. I tried both wired (perffered for me) and wireless.
This NUC has the same network adapter as mentioned above i219v.
Is there some new issue for this device?

This is a known issue, the current software does not support it, due to old drivers and firmware used with debian jessie.
But, there is a solution on the way. Please refer to this post for the next x86 version
It is not completely finished, but the functionality is the same as the released version.
For the latest version, download this one: version 2.781

downloaded latest version 2.799 and installed on a usb drive to use on an intel nuc6i3syh.
no wired or wireless connection.
anything i am missing here?
issue with i219 is still not solved?

it will not be resolved for the current x86 version based on Debian jessie. Newer NUC’s will only work with the alternative version mentioned above, and updates following that one.