Internet radio not working after update

After I’ve updated to version 2.389 (released 26.3.18) most of the internet radio stations are not working anymore. Instead of the radio I only can hear loud white noise. No idea whether this is linked to the update or not, but apart from the update I’ve changed nothing. Strange is That a few radio stations are still playing.
My hardware: Pi3+Allo Kali & Piano 2.1

Very interesting. Exactly my same experience. But I found a workaround because the my favorite webradio content provider had a second (alternate) URI available for each stream. I don’t know why.

For example for 2.387 and earlier I used

After 2.389 I had to change this to

From a SSH session try CURL . If the webradio is working there will be huge character stream until ctrl+C. If the URI is not working then the command prompt returns immediately. You can use command <echo $?> to view the return code if that helps.

Hi Andrew,

indeed interesting! In my case about most of the stations are not working anymore :frowning:
In order to figure out whether this is hardware specific: what hardware is it at your side?

@ all,

because it looks like that it’s linked with the new version:

Does someone know how and where to get the former version?
I would be pleased if he/she would post the link.

Thx & best regards


Hi Axel. Am using RPi3B (not plus) with Hifiberry DAC+, 64GB USB flash for music storage, wifi connection to ADSL router for webradio streaming, generic HDMI 7" touch screen. All pretty standard. There were a lot of webradios by country for Australia. I went through this list and most were not working. This is the first time I have tried any of them so unsure whether they ever worked or only stopped working in v2.389. I do have the RPi image for 2.382 but is 307MB so not possible to send it to you sorry. Best of luck.

Thx Andrew,
by this it looks obvious that it’s not hardware specific, but a bug which affects many users.
Therefore I guess and hope that with the next update it is sorted out.
Regards Axel

IMHO this is caused by an I2S driver regression with the last PI kernel: it cannot play 24bits audio correctly, and all audio streams are played 24 bits.
Could you guys turn on audio resampling, and set bitdepth to either 16 or 32 bits and report back?

Hi Michelangelo,
I’ve tried it with bit depth 32 and instantly it works :slight_smile:
Many thx and regards Axel

I must just be lucky? webradio and local MP3 files all sound great to me with audio resampling off (default) or target bit depth = 32.


will this be sorted out with the next update?

Thx & best regards


Hi Michelangelo,
in respect that it’s still the same after the last update:
will this be sorted out?
Thx & best regards

@Axel this is related to the kernel, and is not something controlled by Volumio … it needs to be changed upstream before it can be applied by Volumio (ie. by the Raspberry Pi Foundation

1 Like

Thx Chsims1, got it.

But by the way, does audio resampling affect the sound? So far I would say I couldn’t hear any difference.

Regards Axel

Upsampling should not affect the sound quality.

Unfortunatley for me the same thing happens when I listen to some of the internet radio stations and DSD songs. After I enable resampling and set the bitrare to 32 it works now but sound cuts out. Any solutions?