Installing Volumio on PC (x86 / x64)

Volumio Information

Volumio Version:2861 22-12-2020
Hardware: ACER Swift 3

I can’t install Volumio from a usb stick on a UEFI pc, after mounting the image on the stick using etcher.
Has anyone managed to install it?
How can I solve the problem?


I recently installed on mine having UEFI Bios. it went well. I tried the X86 debian buster image.

What is the issue you are facing.

We support both uefi and legacy (syslinux) bios.
2.861 is working well with older hardware, I’m not familiar with an Acer Swift, so more information is required.
Try the version from Volumio Development/ Development talks. There is an X86 buster thread, follow the opening post and let us know.
I presume you know how to boot from the usb stick.

thanks for the advice. Yes, I know how to boot from a stick and I also tried another 10 year old computer (Samsung Q330) and everything works fine. I will try to follow your suggestion, but I state that I am not very familiar with the Linux system

thanks for your interest and your response. My problem is that when I start the pc from a USB stick, prepared with etcher, the screen remains black and nothing happens. I have tried on other PCs with bios legancy and everything works fine.

I tried with the 2.861 on my minix and it did go blank when i tried to load from usb. I had restarted the system and forced boot from usb using boot device selection option. But it went well when i tried to do the same after a proper shutdown. I did not face this issue with the X86 debian buster image. So maybe you should try with that too.

Thanks but where can I download the x86 debian buster image, please?

The latest version is 2020-12-11, version 2.857

Acer and some Asus laptops will not run linux because of their bios settings
No provision for legacy boot

legacy boot is not a limitation persé, Volumio also supports UEFI boot since a very long time already (2016?).
I have Asus notebooks here for testing to prove it (e.g. N550J), absolutely no issues at all.

But, notebooks may not boot for other reasons, Volumio 2 has a very old kernel and difficulties with newer hardware.
Using a Volumio 3 beta can (!) be a solution as it has support for the latest storage, graphics, wifi, sound and network drivers, including corresponding firmware.