How to install volumio on large drive

Hello. I have volumio on an old dell pc (x86)

I am trying to set it up for a mate so that it can run headless and essentially network less. So it has a wifi card installed. Simple testing shows I can connect to it with my phone via the wifi so thats great. It will connect via usb to a DAC

To make this a success though it needs plenty of storage. Simple I thought as the dell has 4 sata ports, sadly volumio does not see harddrives attached this way and I have no clue on how to make it see.

I thought a solution would be simply to install volumio onto a large drive then use the spare capacity for the music, so tried to install onto a 3tb sata drive. I simply booted via thumb drive and pointed it at the large drive and clicked install via the system settings, it seemed to go through the whole process but at the end complains thats it failed.

‘Install to disk failed, cannot prepare system for resize’

With this failure the whole system is essentially failed you cannot even boot from the thumbdrive now unless you fully disconnect the 3tb harddrive. I had to remove the harddrive use diskpart on windows to clean it and reinstall volumio onto the thumb drive, I tried the process again with the same failure.

Finally I thought I would keep it simple with two usb attached drives, again volumio only sees one of these.

As you can see in all cases, volumio is preventing me from increasing the size of storage. I am guessing there is a way via command line but as I don’t even know what to search for, I am not in a position to find a solution.

If someone could point me at a webpage or something that would give me a hint that would be super!

Have a look at this thread for installing x86 on hdd. For adding additional disks, you need to understand about ‘mounting’ …have a read here.

Hi there. Thanks for the links, but I am a bit confused.

ON X86 I have successfully installed volumio to HD just by using the GUI in volumio, I have installed it to a 250gig drive no problem from USB stick, but when I try and do it to 3tb drive it does not work.

OK, but does it work with the 3tb drive the manual way as @chsims1 suggested?
I presume there is an error while calculating the disk size.
As the copy feature needs to be extended for eMMC, I will have a closer look and see if it can fixed at the same time.
This will take a while though, it’s on my TODO list, but unfortunately not as a high priority item.

Ah ok, I’ll give it a try then

I am happy to be a guniea pig if you need testing done, but you would need to walk me through any logging you want doing.

The thread on mounting a second USB drive is wayyyy over my head.

This is so difficult. When I put volumio on a thumb drive its essentially a one shot deal, you cannot wipe that drive properly afterwards. I ran SD formatter but if the thumbdrive is inserted sd formatter immediately crashes if volumio is on it.

I can format the thumb drive with a mac, but back on windows Win32 disk imager cannot write to it error 5 access denied even if I run as administrator.

There is something dodgy with the x86 installer to thumbdrives.

OK diskpart sorted it

OK, so basically following the instructions when I list the disk with sudo blkid, the 3tb does not show. I tried another 3tb disk that also does not show

Tried a 1tb disk and that shows just fine.

So in short it would appear volumio does not see 3tb disks. Sigh.

Thanks for everyones help, I am going to try something else as I have to get a solution before next weekend, very sadly its not volumio (I use for may main hifi so really wanted this working)


though this is not helping you at the moment, I still want to thank you for pointing out this issue.
I was not aware of a 3TB limitation until I googled it just before, max. seems to be 2TB.
Not sure yet how to tackle this but I’m investigating.

Just to amke sure, could you try our dev image and see if that one works?
-> Volumio Development / Development talks/ Next x86, first post

But the issue might be more complicated, see this article

Ahh, didn’t really take in the significance of the drive size. I think you need a GPT partition rather than MBR??

Hi, i have installed a hard disk sata and i configured it to boot in udoo x86 advanced with volumio, it hangs and display the message:findfs: unable to resolve 'UUID=6c0d3184-7851-46c3-919b-ed4c1d379708’findfs: unable to resolve 'UUID=CC23-EE0DSpecify the squash image partition on the kernel etc. etc.Do you know some solution?

Hi there, I am not sure if its significant but essentially I had windows running on a dell pc with the 2 3tb drives in it, it ran just fine. I am using the same pc to try and get this portable volumio running, so essentially identical hardware.

I’ll try out that image in the week at some point as it would be interesting to get this going

Hi there, I’ll investigate how to change it, although I think the disk partition programme on windows 10 offers to change it, although I thought running dispart clean kind of wiped that?

Confusing stuffs!

Our x86 image already has a GPT partition, this was a prerequisite to introduce the uefi boot option.
@garethsnaim: you are using uefi boot, right?

Yes tried both UIFI and legacy to install from within gui and to try and run the instructions for manual install, no dice in either case.

oh well, another check ticked off :smiley:
The only 3TB disk I have to test with, will be free by the end of the week.
Let’s take from there, nothing I can do without reproducing the problem first.

OK cool. For now I have installed Daphile, this has seen, formatted and used the drives no problem, so I think the hardware is fine.


I think I located the issue of your disk device not being detected by volumio.
If you can and are willing to edit one codeline to test, then go to /volumio/app/plugins/system_controller/system.
In file ‘index.js’ your will find the following codeblock near line 663:

[code] if (count === 4) {

				if ( diskinfo.device && diskinfo.size) {
					diskinfo = {'device': '', 'name': '', 'size': ''};
				count = 0;

Please change the condition for variable count to 3:

[code] if (count === 3) {

				if ( diskinfo.device && diskinfo.size) {
					diskinfo = {'device': '', 'name': '', 'size': ''};
				count = 0;

There may still be an issue with 3TB (could not test it yet), but the above codeblock is definitely something we need to correct.

Ok off the bat installed the developer version and spotify connect plugin does not work.