How to disable Upnp ( upmpdcli )%?

Is there any easy way how to disable Volumio’s internal upnp ( upmpdcli)?

I have two Volumio devices and some other streaming devices (eg Pioneer Blue Ray) in one home network, installed BubbleUpnp on my Synology NAS and started Lumin on my iPad.

What I can see in Lumin’s streamers list is that both Volumios are shown twice (4 instead 2). I believe the first one is due to internal Volumio upnp and the second one due to Bubble Upnp running on my NAS. When I switched Bubble Upnp off, I can onle see each Volumio device once in Lumin app - which is fine. However I don’t see other streaming devices - Pioneer BD.

So what I think I would need to do instead is to disable internal volumio upnp ( upmpdcli) while keep Bubble upnp running. In this case I should see each volumio device just once and also will see Pioneer BD.

Is it possible to do it?


We are working on a facility to allow disabling upnp\shairport and every service in volumio :wink:

This is very good news! When do you yhink it will be released? :wink:

Wil it also have Tidal support in it?

No ETA for this feature.
TIDAL should be already supported by UPNP (or you can use MyVolumio to get native suppor)