[GUIDE] Setup Audiophonics ES9018K2M DAC with Volumio 2

I bought RPi 3, but with same result. Spotify plays with distorted sound. No error in Volumio.log file. I really don’t know what to do next. Any ideas?

Do you mean there is no longer python serial module error ?
Did you try on the RPi3 with a fresh Volumio installation ?
I suggest to check hardware mode jumpers on your DAC. Are they well soldered ? No cut ? No short circuit ?
Could you post a picture of your DAC with jumpers ?

I did a fresh install of Volumio, I will send a picture of the jumpers in my DAC when I will be home from work. I’m believing that could be the problem.
Thank you very much for your effort.

Here are some pictures20170328_165252.jpg20170328_165231.jpg20170328_165220.jpg

Sent from my SM-G930F using Tapatalk

And the last one20170328_165414.jpg

Sent from my SM-G930F using Tapatalk

Picture 1 and picture 3
There is a problem with the blue wire solder on micro-controller side.
The blue wire is soldered on both pads near micro-controller pin #11. It shall be connected to the pad wired with pin #11 only. Remove extra solder to cancel the short-circuit between both pads.
There is also extra solder on pin #13. Remove it.

Keep wires as short as possible. It should work but the shorter the better.

I give up now, before I ruin my DAC. Audioponics did send me two ES9018K2M DAC’s and I did send one back and starting to think that I send them is the with the right firmware. On the DAC that I did send back had a wire soldered by pin #11.
Thank you for all your effort.

Yes, it was the one with the right firmware…

Audiophonics have agreed that my DAC were without the right firmware and I’ve send the DAC for an upgrade. Will try again when the DAC arrives.

20170508_215025[1].jpgHere I go again!! Got my new DAC from Audiophonics, at still get distorted sound from the DAC. Hardware volume does not work, but I can listen to WebRadios. On discrepencies that I noticed in the mpd.conf file, the audio_output section.

I edited the file as in instructions, but does not change. Can’t see any errors in the log file, but I can’t upload it, got the error that .txt extension is not allowed, or log extension is not allowed…
Now I have a new RPi 3, and a new DAC,

Here’s picture the new DAC


1 - your jumpers settings seems to be ok.
Check each jumper continuity between PCB pads.

2 - try a fresh Volumio 2.041 installation.
Don’t know if the procedure works with most recent releases.

Did 2.041, makes no difference. The wire to the GPIO, is rather loose around the pin, maybe I should try to solder it?

Sent from my SM-G930F using Tapatalk

This wire is the serial link TX line. If it is not well connected then there is no communication with the DAC.
Either solder the wire to the GPIO pin or tighten the socket on wire side.

Got it to work, at least can play Spotify files now :slight_smile:. Thank you very much. But I’m not sure what did the trick. Tried to solder the wire to the GPIO pin, but no luck. The jumper is steady, but the same distorted sound. Tried a few other DAC drivers, but as expected no sound. Ran through the setup once again, and saw that the asound.state file was not as it should be. Fixed that, and edited the boot file as you mentioned in the guide, it changes, edited as it should be, restarted the RPi, and now I got sound.
Next step is to set it up on another SD-card, and use new newest version.

Congrats !

i found something about the 9018 fdac firmware beeing out dated, how can i check this isnt my problem?

i do have to say, i installed volumio, got it to work but the screen didnt work (only see that i need to login)
i can get it to work with the app, but after a hour, volumio freezes and i need to do a hard reset, if i want
to play some music again.

than i found this topic, i have xmas holliday now. so i can figure everythi g out, i realy hope i can get
volumio to work, it does everything i want.