FusionDsp : the complete Dsp center for Volumio3!

Hi Balbuze, it seems that the invert channel switch is not saved in my preset when i try to reload it, is it a design choice? Or a possible improvement :slight_smile:

Hello!
You are right!
The only reason is because I forgot to save it…
This is something not to difficult to fix.
Expect it in the next version :wink:

1 Like

FusionDsp v1.0.32 stable.

  • swap channels setting is now saved in presets.

  • Internal : service location change

Enjoy.

4 Likes

Above all: Thank you balbuze for FusionDSP, it is a sound improvement game changer.

Only one thing, whenever I start a song after boot, a few seconds into the song it goes haywire (screeching noise). I tested it with pi3, 4, two different DACs (Abacus and hifiberry DAC+DSP), and it is always present. When I start/stop the song upon first play, wait 3 seconds, then play, it does not happen. It’s on the latest volumio install with only FusionDSP plugin active.

Oi, while writing here I made another test, turning off the volumio Startup Sound under System/General Settings. And oi again…. no more screeching noise!

Well, thank you :-)))

Hello!
Thanks for your feedback.
I didn’t let the issue you are talking about (and I don’t remember anyone else report it).
But , it seems to occur when a sample rate and/or format change happens.
Can you confirm?
What is your source when you first play? Sample rate, format?
Does it occurs between tracks?

regarding a) no b) independent of source.
It only occurs after boot. Start an mp3 or radio, then a couple of seconds into the song the screeching noise occurs for like 3 seconds, then it sounds normal again.
I can send you a video of the noise, here it doesn’t let me post one.
Greetings

Hi, finally managed to reinstall Volumio on my raspberry pi as well as FusionDsp.

Using Airplay there is no sound, disabled the plugin and sound came through.

Sound is working, I can hear the startup chime when starting Volumio.

http://logs.volumio.org/volumio/no703Vv.html

@balbuze , FusionDSP is great plugin for Volumio.
But I get error and after playing several tracks music stoped
Raspberry PI 3B+
Volumio: 3.396
Plugin: FusionDSP v1.0.32
Full volumio log: http://logs.volumio.org/volumio/QBBdVzQ.html
Please help me understand what is the reason and what can be fixed.

I have the same problem, running version 3.416 of Volumio and 1.0.32 of DSP plugin, my hardware is a RPi 4 and an external DAC connected to USB. After a few tracks it stops playing and a restart will fix the problem, normally I can’t disable the plugin if I don’t restart.

hello,
I’m trying to understand what happens.
@LarsF can you give a log link please?
@Andrei_P it seems your DAC stop working times to times

I also use USB DAC. When I disable plugin fusionDSP, all work normaly.

ok thanks. Did you notice it happens with specific track, sample rate, sources?

@balbuze I will do that next time it happens, last time I tried to just disable the plugin and it succeed after a while, in the task list the command to restart mpd service was running for quite a long time.

Now I checked again. Restart, start playing the track, the next track is no longer playing. Restart again, start playing another track, the next one no longer plays. Each time I started playing different tracks.
http://logs.volumio.org/volumio/WfC9TCh.html

Here is my log http://logs.volumio.org/volumio/TwPPhfE.html

why is your sample rate only 48000? (just curiosity…)

thanks

I did not find where you can change the sample rate in volumio interface.

There is nothing to do. It is just that HW detection in FusionDsp returns only 48000 Hz capability. It’s not common…

2 Likes

I tried to connect the I2S ADC PCM5102, nothing has changed, only the first track plays.