FRITZBOX NAS Stopped Working


@Kodawari cue file is creating problems, please try to remove it from your NAS and check again

/NAS/FB/FLAC/Stars/There is No Love in Fluorescent Light [2017]/There is No Love in Fluorescent Light.cue

So, I plugged into ethernet and moved it to another location in the house (with a different dac).

Initial log (was still fiddling with settings/wondering why it wouldn’t play).
Music DB went blank at 272 albums, and has stayed blank.

After a reboot, audio now working again.
Says 179 albums, have hit update and it got as far as 276 albums before going blank again.

Log below.


Ahh, I see a .cue file there causing problems, will try removing it and updating again.

Removed 40 .cue files from the NAS and rebooted because MPD crashed.

Update - it got to 179 again, so I don’t think it has any issues with those files. I had to update after this and it’s still scanning (slowly - despite being on ethernet).

Success! - All 505 albums now scanned. Looks like a .cue file issue.

Looks promising apart from the MPD crashes.

So, to get NAS from a Fritzbox working we need to:

Delete all .cue files (not required on v3.512)
Add ‘noserverino’ to the share options (also not required on v3.512).


1 Like

apparently the new MPD is much more sensitive to .cue files that are not formatted properly, the old one was less sensitive. Good finding!

I originally thought it was switching streams causing issues with MPD, but after removing the .cue files, it’s stable - think that was causing it.

Stopping, starting, changing webstream/NAS music, etc. no issues with MPD.

Happy that v3.629 is working as expected wih the above settings (.cue files and ‘noserverino’).

When I came up with the “noserverino” parameter, this was because searching the internet shows lot of other Fritzbox NAS users suffering the same issue with other applications (not volumio-releated). So this issue appears to be Fritzbox related, not handling newer kernel/cifs versions very well.