Fritz.Nas Directory tree visible but no music

Hi all,

…as described above. I can browse the complete tree, but looking into the folders shows “No items”. With access via “Media Servers” everything is visible and playable.

FRITZ!Box 7530 with FRITZ!OS: [07.29], Verbatim 64 GB USB Stick NTFS filesystem.
Access with Windows without any problems. I can even rip and Compress files directly to the network drive mapped to Z:

So where is the problem? Just wanted to have it in my library.

Cheers and thanks in advance for any help


PS: of course I tried to search, but I just found similar topics mainly with connecting problems, but obviously connecting is not the problem, just the visibilty of files.

EDIT: Forgot to mention Volumio 3.251 / premium



That was well hidden.



1st. situation: browsing music via “Media Servers” on Volumio will take place using DLNA-protocol.
Both the FRITZ!Box and Volumio can handle (speak) the protocol. In this case the decision to grant access to the files will be made by a process on the FRITZ!Box. I guess this will be granted by default when approach is via DLNA.
2nd. situation: browsing music on a Windows computer via FRITZ!NAS. Probably you are connected to the NAS with sufficient access rigths (=admin?). So no problem here either.
3rd. Situation: browsing music on Volumio via a connected network share offered by FRITZ!NAS.
No DLNA protocol now, just the bare files will be handed over to Volumio. But you will need to have a user account on the FRITZ!Box in order to consider whether the user (Volumio in this case) is entitled to access the FRITZ!NAS. The settings should be made on the FRITZ!Box under “System\FRITZ!Box Users” on the tab-page “Users”.

And then look at the details for the account you have created for this access ( I named it “volumio” )

“Access to NAS contents should be granted, and at least “Read”. Don’t forget to hit the “Apply” button here to make it so, and then reset Volumio to make sure the renews its login on the FRITZ!NAS and thus be granted the (new) access rights. ( I did not configure any specific directories. )
So lets first do these checks. If this does not solve the issue it is more complicated. You could do a quick check by connecting the USB directly to the Raspberry to establish where the problem is. If you can browse you music via directly connected USB, the problem is access to the shared files via NAS.
Good luck.

@itprofi Many thanks for replying. But as I said, this is allready solved (exactly as you described it + the magic word “noserverino”). Works now like a charm on both RPi´s and survived several “hard shutdowns” (i.e. power off) even on the FritzBox (had to “unplug” it from mains due to a heavy thunderstorm we had yesterday).

Now I can rip CD´s as flac from PC directly to the “minimal NAS” and have instant access with my volumios after updating the “NAS” folder.