Fixes for common USB DAC problems with RPi

I’ve had some USB issues lately, seeming something has been overloaded. USB sound is bursts of just noise, DAC delay messages and wifi USB warnings, and the CD ripping stutters. So for now I’ve reverted to the stock kernel without the backported USB stuff and nrpacks=1 to see if the problem occurs in this standard setup too. (Keeping dwc_otg.fiq_split_enable=0).

I got a brief burst of static even on stock kernel and nrpacks=1, so it’s probably not those kernel patches, but more to do with cdrdao overloading the USB bus when getting into trouble ripping a CD. So I’m back on the patched kernel, and the hifi gods may have mercy on a feeble mind, but I do think the nrpacks=1 sounded crap.


It seems that the patched kernel got rid of the few issues I had left on my setup (some noises, USB wifi speed), at least from a 1 hour listening session.

Note that I couldn’t load the driver “snd-usb-audio” with the nrpacks settings in alsa-base.conf. I had to remove it completely.

I also have yet to see the error I had from the wifi driver (chipset RaLink RT5370). Maybe the nrpacks=1 fix is causing a bigger traffic on the USB port. I couldn’t tell at this point.

Here’s my setup
Hardware: Raspberry Pi
OS: Volumio 1.1
WLAN Stick: RaLink RT5370
NAS: QNap TS-221
DAC: SimAudio Moon 100D


Just wanted to stop and say that this works like a charm in my rasp pi --> USB —> Cambridge Audio azur351A setup (not using Volumio though). No more crackling noise.

Thank you


thank you very much! The nrpacks=1 made my AT2020USB+ stop record cracking noises on my Raspberry Pi 3. Now I can record high quality audio in absolute, passive cooled, cheap-hardwared silence! I tried the other option as well but it did not seem to work since it did not seem to have been disabled in the kernel messages. But microphone works perfectly now! :smiley:

PS: This was on Raspbian, not on Volumio.