Does Volumio 3 support gapless CD playback?

By “loud between the tracks”, he means mechanical noise from the drive spinning up to high speed and clicking while seeking the track. It will read the track at high speed, then spin down until time for the next track, and repeat the cycle for each track.

It is related to the problem of the CD drive spinning at high speed, which has not been fixed:
The drive needs to read data at a low speed (no more than about 4x) for gapless to work. Otherwise the drive will spin down if it waits too long for the next data request.

@volumio, I’d like to ask what CD drives have been tested, and can you suggest a model that will stay spinning at a low speed.


I would like to point out, that this is IMHO nothing depending on the CD/DVD-Drive. My Lite-On ES1 is dead silent, when doing playback over windows media player. Even when skipping. And it is well reported that there is linux software, which can do alike.

I don’t know, if it is easy to implement silent and gapless playback into volumio, but since this is a premium feature I would expect that this issue should be solved soon.

Once again thanks in advance to the developers,



Today I received my Apple superdrive and its runs in very low speed after the first track, only runs a little fast in the beginning of each track and then very quiet. Before the Superdrive i was using an ASUS drive which was extremely loud!!
But the gapless still don’t work because every single track the system seems to reloud the track and stays a few seconds in mute.

I bought a USB A cable with 2 male plugs that split power and data, I will test if the drive runs fast because of the power, so supplied constant power from the power source will drive the cd rom smoothly.

I have also installed the apple superdrive, with Y-cable for additional power supply…the speed goes to full speed with every track…what else I noticed, a reboot does not work when the apple superdrive is connected, and 2 power supplies are connected on the raspi, it only works with cold boot

1 Like

same here.
the cut between tracks still goes on.
so sad, I am really enjoying listen to my CDs

hi @volumio!
anythig about the gapless on cd playback??

thank you in advance!

yes I want also gapless playback. Playing cd’s sounds very good at the system accept that every track is loading so you get gaps.

Yes please - this is a deal breaker - specially because we are paying for CD playback, given that you need Volumio Premium for CD playback. This is a serious defect @volumio

Guys, guys, guys. I´d like to chime in. The first complaints considering this were at least three updates ago and nothing has changed. This is a shame taking into account that this is a PREMIUM feature. I remember at least two times @volumio mentioning that this should be no major deal. And it could be one key to not speeding up the CD-Drive in between tracks which also causes an annoying noise.

Especially to the last point: What speaks against setting the cdrom drive to a max speed of 4 using the eject command? Reminder: Volumio running CD drive at noisy high speed - #9 by volumio. Meanwhile I suspect this would cause less problems than the claimed “automatic detection” of the lowest possible speed of the specific drive.

I expect that these are really low hanging fruits and solving this would appease a lot of Premium users.



1 Like

i also think that instead of always adding new features, it’s about time that the problems with the cd drives are finally solved…i designed and manufactured my case for a long time, and now i have a useless cd drive…

that was in version 3.301 (09-06-2022)

Set CD Reading speed to 4x <-------

Ok, but doesn´t work with mine. Typing manually works, but is an annoying workaround. :man_shrugging:



My drive is less noisy now (previously it would run at its max speed 24x and sounded like a jet engine). However, gapless still doesn’t work.

It was me who suggested to @volumio to try 4x speed. However this still seems to be too fast and it continues to do a spin-down/spin-up mechanical delay while playing consecutive tracks. I’d like to suggest now 1x speed which will definitely keep the drive constantly spinning. 2x speed might possibly work but needs to be tested.


Hi Metro, look here, where I tested this manually. And of course I expect the volumio team to have done that, too. There is no noticable difference in device noise, but if I remember correctly, with speed 1x you have to be really patient when skipping tracks. So, yes, I would consider 4x to be the best compromise, too. It only should work.

Also If I remember correctly, the drive spins now more slowly, but not as slow as with manual setting. :man_shrugging:. So something is still wrong.

But back to gapless playback. I´m just assuming here, since I am not deep into system diagnostics at all. I have an external WLAN antenna (USB) on all of my raspis, which start blinking some 10 or 20 secs, before one track ends, which I think is a hint, that the next track is fetched and buffered (At least playing via spotify connect this is quite obvious). When playing CD the drive starts spinning up AFTER the track ends. Why? Solve this one and this could be half the way to get a gapless experience!



the cd playback should be part of the absolute basic of volumio. but the team doesn’t seem to care…anyway i will cancel my yearly subscription, or not reactivate it when the year is over…that the cd playback makes such problems is a nogo

Gapless CD playback works on two other (free!) Raspberry Pi music players I have tried, but they lack some desirable features that are in Volumio, such as Qobuz and Tidal support. It is obviously possible and Volumio just needs to get it done to become a more complete player.

1 Like

Just did

Can you please be a little more clear? :slightly_smiling_face:
Do you mean that is now possible to play a cd on a cd drive, gapless on volumio? If so, is it an update, some settings neeeded, or it just works?

Wheaten moved a few posts in the thread to another thread, so just a remaining post from that and not a solution to your issue…sorry.

So, it´s been a while. Today after I found the time to update all my raspberries and plugins, I decided to give it a try and connected my cd-drive. Surprisingly the drive was quite quiet, so I expect some silent improvements on this side, and I would like to express my appreciation. I would say that I could live with this level of drive noise, but the essential feature still missing is GAPLESS PLAYBACK.

To summarize this thread and some others: …bla…bla… “fairly trivial” …bla…bla… “PREMIUM FEATURE”…bla.

So PLEASE: @volumio “check and enable it” !!!

Some of us will be very pleased…

Thanks in advance