Decoder is to slow

I’m having this issue with a Pi 3B+. I installed on a i5-2400, the same issue!

I’ve tried all possible combinations of buffer size and buffer before play without any luck. I switched from the external USB DAC I’m using to internal audio port, same thing.

I tried to update MPD. Not possible.

I’m trying to compile MPD but there are some dependencies I’ve been unable to fix. May be if I spend more time on this I’ll be able to compile it, but I won’t be sure if this new version will work with volumio or if the issue is actually fixed.

I think Volumio people should consider this bug as top priority. At the beginning I thought it was an issue with my hardware, but all my tests showed otherwise. And sadly, I’m not alone.

The funny part is that I bought 1 year of premium subscription and the android app​:angry::angry::angry: Why should I have to spend time fixing a software that I paid a subscription for?

1 Like

This is honestly the biggest reason that I haven’t signed up for anything premium yet.

The Volumio UI is beautiful, but if it isn’t stable underneath, then it doesn’t really work well enough for me to consider paying for it.

I confirm this is a top priority for us. We did not find a solution yet, as it presents only with some streams and under specific circumstances.

To help us with any pointers please send a log just when it happens and paste the log link in this thread so we can collect as many clues as we can

1 Like

Thanks. The only thing I really see in the logs when it happens is “player: Decoder is too slow; playing silence to avoid xrun” in mpd.log. Are there other logs I should be watching (I’m pretty sure I also checked dmesg for kernel errors), or should I be increasing debug level to get more info?

I always see the “playing silence to avoid xrun” message when the stream goes silent, but I also see it in other instances (when starting a stream, for example), where it seems to have no ill effect.

I also have this issue and as a workaround waiting for a fix I am using a simple script to watch the mpd log and restart it again. I then installed cron and run this script on reboot. Here is the script:


while :
  OUT=$(tail -n 1 /var/log/mpd.log)

if [[ $OUT == *"Decoder is too slow"* ]]; then

  /usr/bin/mpc stop

  sleep 1

Made a quick account to anyone that finds this thread!

The solution by Johan is a great workaround for the issue, thought I’d write this up for any beginners to follow:

  1. Copy the script Johan has posted:

while :
  OUT=$(tail -n 1 /var/log/mpd.log)

if [[ $OUT == *"Decoder is too slow"* ]]; then

  /usr/bin/mpc stop

  sleep 1
  1. Login to your Volumio server via ssh (I’m assuming you still have the standard volumio user)
  2. Type and enter into console: nano ~/
  3. Paste the script into this file then save it
  4. Type and enter into console: sudo chmod u+x ~/
  5. Type and enter into console: sudo nano /etc/systemd/system/mpd_radio_fix.service
  6. Paste the below:
Description=Fix For MPD Radio Play With Volumio


  1. Save the file and run: sudo systemctl start mpd_radio_fix
  2. It should be working! To enable it to start automatically on boot enter: sudo systemctl enable mpd_radio_fix

The cron method would also work but I find this a bit cleaner personally.

Thanks again to Johan!


Thanks for this mini how to

Just trying it :slight_smile:

What are the new “buster releases”, could you expand on it a bit?

I get the same by simply playing flac files from USB.

it is very hard to fix as explained it occurs only in some non defined case. Unfortunately, you are in this case. I’m running several (up to 7) various volumio devices (rpi2,3,4, Asus thinkerboard, Sparky, c4, vim3l) and never met it.
Now, can you try :


according to to your HW

To others having this issue, are you connected via WIFI or Wired?


Okay well either way, I was having assorted problems including the above and switching to a wired connection has solved all of them.

I have had this problem, PI 2B, Volumio 2.806, wired network connection, Radio Paradise.
The PI is built into my HiFi which displays the song titles from the source.
The source would be playing for a few minutes and then the audio would dissapear but the titles continued to update. I have found that powering the PI off completely and re-powering, selecting the source again, does enable it to work again without a problem. However the problem reappears the next cycle.
I have tried to implement the ‘mpd_radio_fix’ listed above but the service fails to start, can’t see why! Doesn’t appear to be permissions.


Bump. No suggestions?

This to me seems an issue with Radio Paradise plugin. I suggest to contact the plugin developer

Thanks for the reply.
Not an MPD/Buster issue?


Just to inform that i’m facing the issue with tidal, never used the radio paradise plugin.

Here my fresh logs on x86:



Unfortunately, Raspbian is released with a very out-of-date version of the Music Player daemon. The version released with Buster is 0.21.5 is some twenty versions behind the latest version 0.21.25. You should install MPD version 0.21.5 first. When it is all working if you are having problems playing certain it is well worth installing the latest version of MPD. Although the thought of compiling MPD may be a frightening one for some of you it is probably worth doing. I have described the process in a PDF document which can be found at I cannot guarantee that the latest version of MPD will cure this particular problem but I have tested version 0.21.25 and it has cleared a number of problems relating to playback issues.

1 Like

Volumio uses a custom compiled version of mpd. In the next release (buster) there will be the latest one…for those who have Thai problem, could you please try the buster release and let us know if this solves the issue?