Dac PLAYBACK MPD-3+RaspberryPi 2+Volumio1.55 choppy/ sound


I wanted to point audio problems with the following configuration:

Volumio functions regularly and recognize the DAC as MPD3 but playing feel like electric shocks.

Raspberry Pi to 2 USB is connected to the DAC and external hard drive powered separately.

How can I fix?

Thank you and congratulations for the software

which power supply do you use?
do you also get these sounds when you are not using the dac?

Check the power source first.

Then read this: https://volumio.org/forum/raspberry-volumio-choppy-sound-t2685.html

In my experience usb DACs sometimes makes such problems - generally some USB HW implementations are scr…wed .
But generic problem could come from power issues.


I tried with another dac “Musical Fidelity VDAC 2” http://www.musicalfidelity.com/support/discontinued-products/vSeries/v-dacii/and works without problems.

I tried using a powerbank 10.000 mah 5volt output with up to 3 amps but the problem remains the same.

I also installed firmware dated 04/03/2015 by rasp-update.

MPD updated to 0.19.9.

Updated volumio with apt-get update now

I think it’s a problem of incompatibility of dac with usb driver alsa.

Did you other possible solutions.

Thanks for the support.

Apparently Playback Designs has a proprietary USB implementation in the MPD-3 and that might be part of the problem. Here’s a description of a patch to the Linux ALSA to handle the quirks of Playback Designs units:

mailman.alsa-project.org/piperma … 54969.html

But that was done back in 2012. I recently hooked up my Raspberry Pi B+ running Volumio 1.55 to a friend’s MPD-3 DAC, and got the same result as you.