Change DAC and Volumio not working?

When I change my dac to a iFi iDSD Neo, the Output Device setting only have two choices:
" HDMI & Headphones", help!
** I use Rpi3b with Pi2AES hat connected to the Neo thru coaxial cable.



Stupid question, but are you sure you did reboot the Raspberry Pi after you changed that setting ?

If you are sure it has been rebooted, from experience, I had problems changing I2S card.
It sometimes requires to re-install the system completely :frowning:
Not too bad as the process takes exactly 6 to 7 minutes… But still.

Not related to Volumio : I had this on other systems too…

Hope this will help.


Yes , I rebooted and still the same :roll_eyes:


Then I think you should try to reinstall the whole Volumio.

For some reason, the same symptoms happen to me on my Pi4.
All the sudden, my HAT DAC or Digicard does not play any sound anymore.
Happens on Volumio but also on other systems (except one so far).

When that happened, I tried to change settings, to disable I2S, to re-enable it… ALl this takes more time than the ultimate solution : take out the SD Card, flash a new Volumio OS to it and place it back into the Pi.

I do not know if restoring a system to the card would work, but if you backed-up your system, it is worth a try.

If re-installing the whole thing does not help, I would try another system just to see if the card is not faulty. I assume your card does have a loittle “LED” that lights up when it is functional. That LED should also flash for a split second when you power on your device. Just check if the LED flashes when powering on the device. If not, it may indicate a faulty card.

Hope this will help.



Oops ! It semes I have mis interpreted what you have been writing.
Your DAC is an external DAC, not a HAT DAC as I assumed.

So please tell us how you connect it to the Pi.

With USB or something else ?

My Hat is Pi2AES, it functions as a DDC, it output thru coaxial to my DAC.
I will reinstall Volumio and try, thank you.
**Actually mine is a Pi4, not Pi3 :slight_smile: **


OK. So you have pi4 with a DAC HAT.

The problem is the DAC HAT is not recognized.

In this case, as I said, re-installing Volumio may be of some help.
I experienced this myself when suddenly I got no sound anymore from my Pi4.
And as I said, I experienced this problem with Volumio but also with other Music OS.
Except one, but I will not name it as it is not Volumio…

Pleased let us/me know if you managed to set your problem.