A few issues with Volumio 3.449 on RPi3B+ via USB and HDMI

Hello Volumio community!

I have been trying everything Volumio 3 (most recent release) can do on my RPi3B+ and over I’m very pleased and considering switching to Premium if the solution can be a full replacement of my current setup – hint: so far it’s not (yet).

Base system: OPPO BDP-205 using a USB HDD to play stereo (FLAC,DSD) and multi-ch (DTS, DVD-A, DSD) using the internal ES9038PRO 8-ch DAC for a decent Stereo / 5.1 speaker system. In that configuration, I do not use the USB AUDIO in or the HDMI in for music. I do however use UPnP up to the supported 96kHz/24-bit.

Everything works perfectly well but bringing the HDD over from my office room to the living room + using the rather bad/abandoned OPPO app on the phone or having to power on a TV display to navigate the files is annoying. It is tedious but manageable.

I recently purchased a Denafrips Pontus II 12th (stereo PCM/DSD DAC) and the USB input sounds a lot easier to manage than the HDMI or an extra I2S HAT. I had a RPi 3B+ lying around and… Google quickly brought me to the Volumio website. A fresh SDCard later I’m up and playing, filling up /mnt/INTERNAL/ with all I have.

Here are 4 issues I found with Volumio, from most critical to trivial. Maybe you could kindly point me towards posts I’ve missed that found a solution to these problems?

1] First ~1/3rd second of playing a new file is cut-off in USB, ~2 seconds in HDMI.

That happens on all devices streaming from Volumio and is a deal-breaker to go Premium for me. I have seen the complaint popping up in the forums but I haven’t found a fix this, seems to be related to speed negotiation with the device?

For example, Bill Wither’s “Ain’t No Sunshine” in DSF will start at “… no sunshine” on USB and “…n she’s gone” in HDMI. Kills the intro.

The OPPO never skips a bit when playing any file so the issue is not the receiver but the sender (Volumio). It “feels” like Volumio starts negotiating the traffic while sending the audio data, instead of sending… silence? until the handshake is completed?

2] UPnP resampling

Card 0, ID `b1', name `bcm2835 HDMI 1'
    sampling rate 8000..192000 Hz

 Card 5, ID `P1213', name `DENAFRIPS USB v3.12 | P12.1.3'
    sampling rate 44100..1536000 Hz

I have tried everything (including meddling with the /etc/ conf files and stop/start services) but UPnP always defaults back to 44.1kHz/16-bit on Volumio. It doesn’t seem to probe the target device for capability and adjust to the maximum available quality like the OPPO does.

I’m using Foobar2000 for UPnP server with specific profiles set for each DAC. All set to accept these ranges 44.1~192 | 16~24 and Volumio only agrees to 44.1/16 with no playing mode information on the server side, which is consistent with no capability probing/adjusting.

=> Is there a way to increase the max quality of UPnP somewhere in Volumio?

This is not a deal breaker but it might be a very easy fix to simply set somewhere in the configuration files (via SSH) what my max specs are.

3] Multi-channel support

Card 0, ID `b1', name `bcm2835 HDMI 1'
    1..8 channels

I have tons of multi-ch files from my CD dts/SACD collection. I play them easily with the OPPO and wondering if, using HDMI since the DACs are stereo only, it would be done with Volumio as well (even as a hack, not as part of the distribution).

I tried DTS but they play stereo channels only.
I tried multi-ch DSD and they crash MDP.
I do not have DD, DTS-HD or other MPL files to test at the moment.

I know multi-channel is not supported and is a lucky win if it works by chance but…

=> Has anyone succeeded in playing Hi-Res multi-ch with Volumio 3 over HDMI?

4] EMOJI in titles/tag will prevent playing.

Ex: Mr.Children – I :heart: U
Maybe the system default to UTF-8 instead of UTF-16?

=> Could it be possible to move to UTF-16?

Everything else works REALLY well and I started advocating Volumio on RPi to all my friends into music, DACs, Hi-Res, etc. Very good job there, hope to join as a premium eventually!

Thank you for reading it all.


Hi and welcome to Volumio,

Could you please eleborate a bit further on how your Playback routing exactly is? You have a FLAC/DSD file on your internal storage (SDCARD) of the Raspberry Pi. The Raspberry Pi is connected to the OPPO via USB or/and HDMI? Could you also tell me if you are using an original RPI PSU. If not what is the maximum A of this PSU?

  1. The OPPO never skips a bit when playing any file so the issue is not the receiver but the sender (Volumio).

Do you mean by this you have tried to play a file, preferbably the exact same file, once via Volumio as source. And once from a other source?

  1. Could you please check your playback profile of Foobar2000? UPnP should be able to play higher resolution files without any changing of files. Note that if you send an 8 channel file this may cause resampling.

  2. Volumio does not support native multi-channel playback. Volumio is focused on audiophile stereo playback. As far as I am aware there have not been any community solutions either.

  3. I cannot currently answer this I will have to try myself. It could be handy if you would provide the logs of this from volumio.local/dev

Thank you for the quick and detailed answer.

  1. You’re correct: I tried – to have a base for comparison – to play PCM and DSD from Foobar2000 / Win10 / USB to both my USB DACs and they do not start with a cut intro, they play the track from the beginning, as expected.

Haven’t tried in HDMI yet but it should be the same.

Path is FLAC/DSD file on the SDCard, exit is either:

a) USB out to the Pontus II
b) USB out to the OPPO
c) HDMI out to the OPPO

Power source is the official RPi model (T5989DV PSU, RPI, 5V, 2.5A, MULTI PLUG BLK) from Element14.

  1. Quick win with UPnP

You made me question my Foobar2000 profiles and it seems that it doesn’t match the profile with “User-Agent contains Volumio”. Setting the profile “default” to 44.1 ~ 192 max 24 bit, no processing, stereo only and right now Bruno Mars’ 24K Magic 96kHz/32bit is streaming in 96kHz/32bit (must be a 24 → 32 padding), or David Bowie’s Starman in 192kHz/32bit, bitrate confirmed by the DAC.

It seems that, when restarting Foobar2000, default will be 44.1~44.1/16 again.

=> But issue solved! It was on my side.

For the record, I tried to play a DSD64 file and both Foobar2000 and Volumio player crashed (red error popup on screen). Probably not a good idea!

  1. Understood, had low hopes anyway. Will keep tinkering with various files, formats and player to see if anything meaningful can be achieved.

  2. I just edited the tags to replace the :heart: with “I LOVE U” but I will re-upload soon the files to see that the logs tell us about unreadable tags.


I am not sure what happened but this time, after reloading the album with the Emoji in the tags and filenames, it worked normally…

{"status":"pause","position":0,"title":"1 - Worlds end","artist":"Mr.Children","album":"I ♥ U","albumart":"/albumart?cacheid=991&web=Mr.Children/I%20%E2%99%A5%20U/extralarge&path=%2FINTERNAL%2F2005%20.%20I%20%E2%99%A5%20U%20%5B2005%20Toy's%20Factory%20TFCC-86200%5D%20%5BHDCD%5D%20DR10&metadata=false","uri":"mnt/INTERNAL/2005 . I ♥ U [2005 Toy's Factory TFCC-86200] [HDCD] DR10/01 Worlds end.flac","trackType":"flac","seek":7736,"duration":333,"samplerate":"44.1 kHz","bitdepth":"16 bit","channels":2,"random":null,"repeat":null,"repeatSingle":false,"consume":false,"volume":100,"dbVolume":null,"disableVolumeControl":true,"mute":false,"stream":"flac","updatedb":false,"volatile":false,"service":"mpd"}