5 GHz wifi support (posted in correct forum this time)

I’ve looked at the other posts similar to this one and haven’t seen a fix for this.

I’m running Volumio 2.834 on 2 Pi 4s. Under Volumio neither Pi can see any of the 5GHz networks in my house or neighborhood. Under Raspbian both can see the 5GHz networks. Is this working as designed?

I posted this in the general forum by mistake. I noticed when I deleted it that deletions don’t necessarily take effect for 24 hours. Sorry for the double posting.

1 Like


No worries for the double post, we’re all just human :wink: I’m not sure why it doesn’t work, a quick check on my Pi3 confirms it cannot find the 5GHz network.

1 Like

My rpi4 sees and uses my WiFi 5g

Hi there,

My Pi4 also shows all 5GHz nets, you can check which bands are supported by running sudo iw list | grep MHz; if the 5GHz bands show, the adapter supports it. If you want to check whether or not it’s Volumio, just run sudo iwlist wlan0 scan | grep SSID:, all nets scanned by the adapter should show (and should be visible in Volumio as well).

As for my previous post, the Pi3 does indeed not support 5GHz :wink:

I tried iwlist scan wlan0 and the list it returned contained only 2.5 GHz networks. I verified it by using a wifi scanner app on my phone. I have 2 Pi 4s running Volumio and both are within 15 feet of the router. Signal strength is -52 dBM for the 5GHz network in my house measured near the Pi on my desk. When I was running Moode on both of these Pi 4s, forgive the mention of a competing product, they saw 5GHz networks without a problem.

Tried looking for Frequency and SSID (grep -e “Frequency” -e “SSID”) and discovered that the Pi saw a couple of 5GHz networks neither of which were mine. It didn’t see my main router or the wired access point downstairs. Interesting.

The antenna of the Pi isn’t the best and since 5GHz is heavily impacted by any structure in between, you might not get the same results as mobile devices. You could try a USB WiFi adapter, that might yield better results

There are two things that puzzle me. First, my 5GHz network has the strongest signal of any 5GHz network visible to my desktop, tablet, and phone. Second, on both Pi 4s, both Raspbian and Moode detect my 5GHz network. I also have a Pi 3B not running Volumio that detects the 5GHz network. It’s not the end of the earth. The 2.5 GHz band is fine for streaming music. At the Pi 4 on my desk 2.5 GHz signal strength is -49 dBm. The 5 GHz strength is -54 dBm. Either would work if I had the choice. I just find it peculiar that Volumio is the only Pi software I’ve tried that doesn’t detect my 5GHz network. BTW, I’ve tried to use the manual entry of the SSID in the network configuration. It fails. The good thing is that I’m retired and have the time to spend chasing first world problems like this.

If you have time, you should try with the experimental Buster version of Volumio Beta Buster

Just a hunch, have you tried setting the right country code in the wpa_supplicant?

Thanks. That appears to be it. The wpa_suppliant config file had no country code specified. I added a line specifying US and the 5 GHz networks are available. I was able to connect to the one I wanted.

Glad it fixed your troubles!

We really need to add a little more localisation support – more than just the language. The time zone and country code could be smartly integrated into the “First Start” wizard…

EDIT: I see that there was some discussions, but never reached to anything conclusive…

Yup. Exact same problem. I can log onto the 5ghz band eventually but as soon as i reboot, its a brick. Definitely specific to volumio because the same board using raspbian works foawlessly with 5ghz