2.799 Not Bootable RPI 3B+


I spent a bunch fo time yesterday trying to get the 2.799 release to work on my existing Raspberry Pi 3B+. From what I can tell, 2.799 is just not bootable on that hardware.

I started with the in place upgrade which would not boot. I then re-imaged the SD card multiple times without success. I tried to a new SD card and had the same result.

I imaged the SD with 2.779 which did boot. I then tried the upgrade again and it would not boot.

I attached the Pi to a monitor and there’s no bios/boot output at all.

I would appreciate any help. Also, let me know if there are other steps I can take to help debug.

Thank you,

I’m not sure why that would be happening.
I’m running a 3B+ too and the upgrade worked and mine has been running 2.799 for a while.
My update was from 2.779 the same as you’ve tried.

What happens if you enable test versions, and update to V2.802?

I have a spare 3B+ and can try.
Do you have specific hardware (dac, touch screen etc.)?

I don’t have problems booting with that version on RPi3, most of the people don’t have as well.

I suspect your SD-card is the “guilty” for your issue, do you have another one for testing if you have problems flashing again the same version?

Yeah, when I didn’t see other folks reporting the same problem I assumed it was probably just me, but I’ve yet to find an explanation or a work around.

I have tried two different SD cards, and I’m back on the original card running 2.779 without any issue.

I’ll try the early release 2.802 today for the sake of argument. I’l also try 2.799 on a different 3B+.

The boot process fails so early, I don’t imagine it would have to do with the DAC, but I’m running the original NanoSound DAC with OLED screen.


Ok, I tested my second SD card with 2.799 on a different 3B+ and it does boot correctly.

This might imply that the issue is with the NanoSound DAC. I’ll try pulling the DAC and see if the original device will boot 2.799 without it installed.


1 Like

Please let us know, we are trying to clear all the issues associated with this release

Ok, I have more information. I pulled the DAC and tried the second card with 2.799 and the device won’t boot.

However, looking carefully at the motherboard, it’s not a 3B+: it’s a 3B v1.2 from 2015.

I don’t know if that is helpful.

Thank you,

release v2.799 works on my RPi 3B+ with hifiberry AMP2 for me (despite the snapcast issue I would really love to see fixed - any idea about that ? :smiley: )

I have tested both with an 3B+ and the 3B.
Both work fine and both successfully updated from v2.779 via v2.799 to v2.803.

Continuing to test. I took the card with 2.799, booted it in the 3B+, enabled testmode and upgraded to 2.806. Rebooted, confirmed it was still working in the 3B+.

Then I put the card in the 3B and once again: it will not boot. There is one flash of the green activity light and then only the red power light stays lit.

I don’t know what else I can offer. I can keep trying the beta releases until one boots on this 3B, but I have no explanation for why this Pi is different.


What happens if you deploy a different OS (with the same kernel) ?
According to the docs, Volumio v2.799 is based on 4.19.118 Kernel for Raspberry PI.

I have the same problem. My Pi 3B+ won’t boot with Volumio v2.799 and even v2.806.
The red led stays on, the green led isn’t blinking.

early version are working perfectly
I also have the RPi 3B+ with hifiberry AMP2


could you please try to boot removing any DAC/AMP attached to your RPi?

Even after disconnecting the hifiberry amp2, the pi won’t start up. The green led flashes once.