2.389 No Sound from Kali / Piano

Updated this morning. No sound comes out.

Had the NAS mount issue. “version=1.0” fixed it.

Visually, tracks look like they’re playing. No sound.

Radio looks like it is playing, but again no sound. Tried the resampling suggested in the radio hiss thread. No luck.

I see this several times in the log file but it’s meaningless to me.

" error: MPD error: Error: This socket has been ended by the other party"


Thanks for any suggestions.

I ended up using the back up and restore plugin. Then I factory reset it to move to an older version. Still no sound.

Ran the update again. Can’t mount NAS. “version=1.0” not fixing it this time.

Reflashing SD .

Reflashed SD card to 2.389. Wished I hadn’t deleted all my old ISOs last week.

Realized I needed “vers=1.0” not “version=1.0” Whoops.

Plays FLACs fine. Had to turn on resampling for some web radios and for MP3s.


Power failure a couple of days ago killed one of my Volumios. mSD card doesn’t mount at all – added to my growing pile of dead cards. (they sure seem to be fragile) Reloaded the iso and everything looks to be working, but I’m getting no sound from the Kali/Piano again. Any suggestions for a setting, tip, or tweak I’ve forgotten?

NAS mounts and scans. Queue works. Claims to be playing. The display shows play progress in song…

Works fine with the USB Dragonfly.

Have the same setup as you and everything works perfectly. Have you switched on i2S dac under ‘settings/play back options’ and selected Piano 2.1 as Output Device and DAC?

Yes. Except I don’t have the 2.1. Just the regular Piano. I’ve switched it to piano and back to something else. Rebooted and switched again. Maybe I should try the 2.1. I’ll let you know if it works.

So for my setup at least, using the 2.1 DAC choice with the 2.0 means everything locks up and I reinstall from scratch.